Issues with files appearing to be corrupt, hearing pops


I’ve had a few issues with files appearing to be corrupt. Hearing pop, replaying, same.
Playing a different album (Hires FLAC of Mark Knopfler from
That one sounded corrupted as well.
I’ve rebooted Roon core (ROCK running on NUC, music on internal SSD), then the second album started to play properly.
Tried the first album (the one sounding corrupted), played fine as well.
All versions are latest.

1 Like

Hi @Michael_Borodiansky ---- Thank you for the report and sharing your feedback with us. Both are very appreciated!

Moving forward, have you tried working with the mentioned content outside of the application since noticing this “popping” behavior? I am just curious how the media responds to other applications.

Furthermore, can you please expand on the description of your setup using this link as a guide. More specifically I would like to have a better understanding of the endpoint that was used when you made the above observation(s).



These files played quite well before on the same setup.
They also played well in Audirvana Plus.

The setup:

Roon Core: Intel NUC. Core i7, 16GB RAM, 960GB SSD internal Music drive.
Running the latest version of ROCK.
Switch: Ubiquity gigabit PoE Ethernet switch (both Roon and Endpoint are connected to non-PoE ports)
Cabling: Cat 6 and Cat 7 cables.
Endpoint: Sonore microRendu.

The noise was more like a bit of a scratch, not a pop. The album was purchased from

The second album was also from there:

I’ve replayed the same track from the Privateering, and the same spot would sound scratchy.
After rebooting the Roon Core (Red button on the top - reboot), I’ve played the albums, they appeared to sound normal.
I’ve looked at the Roon logs, and saw complaint about corrupted files.
I’ve also experienced (slightly before and certainly at that time) the case where Roon would just skip the song.
The ffmpeg version was 3.3. I’ve replaced it after submitting the report with 3.4.

The background processing is disabled.
The endpoint DSP is disabled.
The endpoint volume is fixed.

Update: Just updated to the latest version of the software:
Roon Version 1.3 (build 274)

Many thanks in advance,

Thanks for touching base with me @Michael_Borodiansky, I appreciate you taking the time to provide the requested feedback :thumbsup:

Moving forward, I would like to have our techs take a closer look into this behavior you are experiencing and would kindly like to ask you to provide the following materials to help aide in their investigation. Please see below.

  • A two media samples that you have experienced this behavior with. If you could provide the content in a shared dropbox link that would be ideal.

  • Screenshots of …

    • Your signal path leaving Roon when you are hearing the mentioned “pops”.

    • The settings you are using during playback when the error occurs.

  • Please verify what the microRendu is feeding into.



Please find attached the screenshots of the audio path (together with the song names from the two albums in
The album was purchased from

The second album was also from there:

I am sorry, but I’m unable to share the tracks themselves :frowning:

The microRendu is connected to Chord 2Qute DAC.
Please note that after the reboot the songs play without distortion so far.
My apologies for incorrectly describing the distortion sound:
It is more of a scratchy sound (fairly short) than pop. But close enough to it.


One more thing:

The album that caused most of the distortion was in ALAC 96Khz/24-bit.
Not sure if that helps.