Issues With HQPlayer

Hello,

In my latest issue of what I like to call my dumb machinations, I decided to setup a single machine that would:

  • Run Roon √
  • Allow for remote access with OpenVPN TAP √
  • Upsample with HQPlayer and stream that information via HQPlayer’s NAA

I’ve successfully completed 2/3, and have a working install of HQPlayer Embedded on the machine. My problem is that that install can’t see my HQPlayer NAA running on my computer. In fact, the only way I can get the NAA to work at all on my local network is if the NAA is running on the same machine as HQPlayer itself.

As you’d imagine, this kind of defeats the purpose. I’m wondering if I’m missing something but can’t for the life of my figure it out. Windows Firewall is just outright disabled on my computer, so…

Thanks,

~RKarim

Problem is likely the VPN network adapter and that multicast routing ends up going there instead of your local network. You need to ensure that multicasts are routed to the local network in order for NAA discovery to work.

Hello Jussi,

Thank you for your response. The key problem is that HQPlayer won’t find an NAA period on my network (even outside of the VM). As I stated in my original post, the only way that HQPlayer NAA works at all on my network is if I run the NAA and HQPlayer on the same machine.

If I have my laptop running an NAA and try to connect via HQPlayer Desktop on my totally normal, non-VM computer, it still doesn’t see the NAA.

Thank you for your advice so far.

~RKarim

Have you checked that in OS of your HQPlayer computer and NAA computer there’s only single network interface active (including any virtual interfaces like VM or VPN interfaces)?

You could check routing table of your HQPlayer computer to see where multicasts are being routed. Typically this is where default route points at (internet gateway).

The IP routing table does in fact point ‘0.0.0.0’ to my networks default gateway. On my NAA computer, there are definitely multiple interfaces were active though, which I disabled- to no avail.

Here is a link to my Linux routing tables: https://i.imgur.com/SPMajd1.png - I’d be lying if I said that I wasn’t a little out of my depth here, maybe you can make more sense of them.

Here is a link to an ifconfig: https://i.imgur.com/e1UX6XZ.png

Thank you for your help.

~RKarim

Hard to say, but could be the VPN messing things up. Or any firewall active that could be blocking traffic?

Update for you. NAA works on all devices except the host of VM after screwing with routing. This is fine for me as my host is eventually going to become a NUC.