Issues with Nord VPN

Hi, I hope this is the right section to post this. I’m having problems with Nord VPN and my ultrarendu. If I have Nord running then although Roon can see the device Nord seems to block its ability to play. Nothing happens when I ‘press’ play, it just sticks at 0.00. If I turn the VPN off then everything works OK, turn it back on and it’s fine until I stop playing music and then try to start again.

On the sonicorbitor site then ultrarendu doesn’t show up. Somehow its being blocked from the network.

I’ve looked through the VPN options but can’t seem to find a way of getting it to not block whatever it’s blocking.

It’s rather dysfunctional as it stands. I’d much appreciate any help with this,


1 Like

You need to provide more details. Is Roon Core running on your computer that NordVPN is on? I suspect that would cause the problem.

I have Core on a sonicTtansporter and all endpoints are n the same LAN without the interference of any VPNs. But I use NordVPN on my remotes (MacBook Pro, iPhone, iPad) without problems.

If I understand correctly, You have a Roon-Server (on the Same PC as the VPN?) and a Sonicorbitor in your Network as well as a Ultrarendu!? If You activate the VPN You can’t get Roon to play on Your Ultrarendu, right?

I don’t know Nord VPN but I know VPN’s in general. Check for a option named Split Tunneling or somthing that blocks access to local Networks. I found this: What is Split Tunneling and how to use it? | NordVPN support

Set the Roon App to not use the VPN and try again.

VPN’s build a Network-Tunnel to a Remote-Server. All your Networktraffic ist send down this Tunnel (even the one that is supposed to be local). With Split-Tunneling you can configure the VPN in a way that not everything is send via the Tunnel to be able to access local Network-Ressources while the Tunnel is active.

I hope this helps.

1 Like

Are you doing this to get Arc working?

You mean use VPN to use Arc? That’s not necessary since Arc works with Port-Forwarding on Your Router wich lets a connections on the specified port on you Router in. Its like a little door for your Roon Arc connection to pass through.

For people with CG-NAT networks cannot port forward. So a VPN is needed. Even an external router won’t help my case (I have one).

Using Nord VPN’s Meshnet feature (on Windows Roon Server install) with ARC to get around problems with Verizon-Fios CG-NAT etc and it has been working flawlessly.

Ahh okay, I get it. Sorry didn’t know about the common apperance of CG-NAT. Never had Problems with that in Germany. Live and Learn I guess

Wait can that feature allow me to port forward on my phone or will I still need to install VPN on my iPhone?

Yeah T-Mobile Home internet is still very new internet here in the US.

Meshnet needs to be enabled – and therefore Nord app installed – on any device you want to be connected to the Core when outside your home network. I don’t run Nord’s VPN just Meshnet on my phones and Chromebook.

Oh ok. I’ll have to see if I can get it. I’ve been using tailscale lately.

1 Like

Thanks for that, unfortunately, Nord can only do this on PC by the looks of it… TYpically I’ve just changed back to Mac!

Looks like a separate Roon Core is in order

Good luck :crossed_fingers: