Issues with Pi 4 and Ropieee w usb dac

Hello folks. I’ve got a PI 4 w 4gb and I was planning on creating a room endpoint with it for my usb dac. I followed instructions flashing as card with Ropiee and then putting it into my Pi4. I had connected Ethernet cable to the Pi and had the as card installed. I powered it on and it said it had flashed Ropie to it and it saw network connection etc. after doing such I connected my dac via usb to it amd this is where issue runs. I don’t see the endpoint in a room. Also how do I enable WiFi using Ropieee. I feel like I’m doing something wrong here.

Help please?

Ok so I can see it now only if Ethernet cable is attached. How do I enable WiFi. I did not see anywhere after it booted up where I could do such. As soon as unplug Ethernet it’s not seen.

Hey Shawn, while connected to ethernet, using your browser, connect to the RPi. Configure as below. Then reboot.

1 Like

Check out the excellent Ropieee Guide for Beginners.

1 Like

Thanks. So I’ll need to be attached to Ethernet I take it again to access this menus?

Indeed. You plug in the Ethernet cable. Visit the admin web page to configure the wifi (enable, reboot, then configure).

Once you’ve configured the wifi you can unplug the cable. From then on onwards you can always reach the admin page via wifi too.

Also, check your roon-core firewall. Make sure the firewall is disabled or you open all necessary ports. In case you need the list of needed ports, they are:

TCP/IP Ports 9100-9200
TCP/IP Port 52667
TCP/IP Port 52709
TCP/IP Ports 63098-63100
TCP/IP Port 49863

UDP Port 9003

1 Like

@Kentaga_Kartadinata Can you please comment on what these ports are for? And how did you get to identify them?

All set now worked perfectly. Ty so much for your help on this.

I actually got these ports from this forum. Somebody had a connection issue that turned out to be firewall-related and posted the port list, so I have the list saved in my notes in case I need them. :slight_smile: