Issues with search bar - X doesn't work [Resolved in build 778]

Core Machine (Operating system/System info/Roon build number)

Innuos zen mark 2 version 1.4.7 roon build 1.8.763

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ASUS router rt-ac3200 connected by Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Innuos connected via USB to Hegel H390.
Using iPad Pro 12.1” 2019 model running roon endpoint 1.8 build 763

Description Of Issue
Search bar problem

Search bar much smaller so doesn’t show sufficient on long title details, but as typing and results are filtered, once a choice is made everything is fine. However, next search leave previous search on top line which won’t clear when tapping X it just closes the search box. Consequently initiating a new search means having to backspace repeatedly to delete the previous search till box is clear to type new search.

Same result using different endpoints (all iOS).


The text should be highlighted, so start typing and the text is overwritten. The ‘X’ is for closing the search box.

That’s how the previous version worked but not this one…no highlighting occurs.

Also having the same issue here. Using Roon Remote version 1.8 build 763 on an iPad Pro 12.9” 2020 model.

Pressing the search magnifying glass does not highlight the last search text. Instead it places the cursor at the end of the last search text. Pressing the ‘X’ closes the search box. Which is not an expected way of working.

Hey @SeanB,

Thanks so much for taking the time to report this. And @Rory_Sharp as well.

This is something we’re looking into. While I cannot make any guarantees on if and when this will be changed, we do appreciate you sharing that having a better way to search for longer titles would help.

Thanks :slightly_smiling_face:

1 Like

It happens the same to me. Problem 1 the small search box, very uncomfortable. In the previous world it was large. Problem 2 is a big big problem: pressing X doesn’t delete the words, we have to backspace one by one. Really horrible with this essential search function that we use all the time.

Thank you . Hoping you will fix it!


1 Like

Just as an FYI, if you didn’t see them, other users have been discussing this issue:

1 Like

Thanks @SimplicityCompass for the context! Really helpful :slightly_smiling_face:

1 Like

@beka - I think you missed the main point of the complaint. The main issue people are having is searching using iOS on a iPad, not necessarily searching for longer titles. The issue is that old searches remain in the search box and have to be deleted one character at a time rather than the box clearing automatically.


@Duckworp, I appreciate you putting that into words. It will now be taken into account by our technical and QA teams as they approach this issue.

When will this be fixed? This is annoying as doing searches is happening very often when using Roon.

Hey @Markus_Hubner,

Thanks for sharing how important this is to you. It matters to us as well, however, I don’t have a set timeline to share. We will update you on this thread as soon as there is an update to share.

Thanks in advance for your patience :pray:


Once a search is entered in My Album, Roon correctly produces the results. However, when the search box is clicked again, it is not possible to clear the last search by clicking the “X” on the right of the box. Instead the search box just disappears.

iPad Pro 12.9 (2018).


1 Like

I have the same problem. iPad Air 3rd gen. I also assume that an “X” on the right side of a search field will clear the search term in that seach box. Currently, you need to tap backspace for each character in the seach box to be able to search again.

1 Like

This has been an issue since the release of 1.8. :scream:

:cricket: :beetle: :spider: :scorpion: :mosquito: :ant: :bug:

1 Like

@support is this on the bug list ?

I am using iPad Pro 12,9 2020 on 14.4 and see the same thing

Hello All,

Thank you for the reports, we’re aware of this issue and we’re working on it.


Hello,if i use the search window on 1.8 its not possible to use the x to delete the search word. By using x the search window closes instead of deliting the search word. Tks Alex

1 Like

Yes, it is a known issue, Roon are working on a resolution:

Thanks @SimplicityCompass! :pray:

1 Like