It is not possible to add music with metadata

Hi there,

I also have this issue since 1.7 build 710.
An older topic from November 2016, where this problem occured has been closed already. The conclusion was not found but one thing was clear: It was NOT the network configuration which lead to these problems.

Why do I have this problem since 1.7 Build 710?
Has there changed anything?
Is it maybe the new function “Valence”?
Btw. What is this? I only read somewhere over it. I did not recognize any change belonging this.

Please help to get rid of the red triangle. Everytime this symbol comes (several hours after a complete reboot of my selfbuilt Rock NUCi78BEH) it is not possible to add music with metadata.

Thank you very much.
Best regards,
Manuel

Hi @El_Manu,

Typically this occurs when there is some type of communication problem with our servers. Can you provide some details about your network configuration?

I am connected wired over a HP 1410 8G Switch to a AVM Fritz!Box which is connected via coaxial cable to vodafoone/unitymedia. I have no issues with my connection. Even the sensible VPN connection to my workplace is stable at all the time.

It worked now for 4 days without problems after a restart.
After restarting again it now occurs and is not solvable by restarting again. I have no idea, why there are the problems now again.

Take off the VPN and see if that works.

the ROCK Core is totally another Computer in the network and in my fritz box nothing is configured for vpn. So that cannot be the solution.

The issue persists even after restarting now. New Metadata will not be filled in. I added the music 10h ago.
Network: Nothing has been changed since it worked properly 4 days.
I have no more clue, what this behaviour causes.
btw: Roon is up2date.

Configuration of my router:

Every traffic is allowed to this IP (which never changes, because this MAC always gets the same ID from the router) Every port setting is allowed to the rock and will be self set, if fritz!box gets this wish from rooncore.
So: Problem persists.

Problem was there after I was forced to restart the core because of changing the power cord. Before it worked properly 4 days.

Maybe, I have the solution and I remembered, how I got roon to run properly 4 days, the last time:

By rebooting the whole machine (red button in Web Interface) the meta data / Software version error comes up again.

Hi @El_Manu,

How are your DNS servers configured on the router, are you using Cloudflare DNS, Quad9 or Google DNS? Did restarting just Roon Server via the Web Interface resolve the issue this time around as well?

Hi @noris,

my DNS Servers are at standard settings. I will attach a screen from my configuration:

I do not use any of the named services like Quad9.
This time it also helped. When only starting via red button, and not restarting via “Roon Server Software Restart” it took around 1 day it the error comes up again.

1 Like

Hi @El_Manu,

Thanks for the screenshot!

Does this error by any chance occur when your IP address expires?
If it occurs after exactly 24 hours that could be a clue.

1 Like

We do not have a forced redial-in. My connection is steady up.

@noris means when the lease on the IP address issued by the DHCP server in the Fritz!Box expires - not the connection to your ISP.

Noris - if you look at the screenshot that Manuel posted, you can see that the lease time is set to the default of 10 days, so I’m afraid that disproves your theory.

2 Likes

Hi @El_Manu,

Do you by any chance have VOIP capabilities enabled on this router / modem?
Can you note the exact local time + date you next see the error occur?