It's back...deleting library and adding back over and over

This issue had basically stopped with the initial 1.3 release, but since build 203 Roon is back to randomly and frequently dumping the entire library and re-adding it…over and over…and over…

Current setup, Roon Core version 1.3 204 on a Mac Mini running the latest OSX install and patches. All files stored on a Synology Diskstation 413 running 6.02 build 8. Everything is hardwired using Ethernet and switched via a HP 1420 Switch.

The core is mapped to the NAS via the local folder. Previously, this was the only way to get it to be stable. Any combination or network path caused the problem in the past, and mapping locally was the only work around I found. Please help!

Hi John,

Just to get the picture complete for support: how many tracks are in your library? Of what vintage is the Mac mini (CPU/RAM/Storage)? Is the HP switch you mention a managed or ‘dumb’ switch?

Can you check if jumbo frames are enabled anywhere on your network (Mac/switch/Synology) and if so, try to disable them?

Jumbo frames are disabled following previous advice. It’s a late 2012 mac mini with an intel I5 processor, 8gb ram and a 256 gb ssd. The library has 7300 albums and 152,000 tracks. The HP switch is unmanaged. An Asus rt-n66u router provides the management.

150K tracks is no small library, but I can’t see any reason why it should not run OK on your current hardware. This looks like one for @support to look into – I have flagged them so they can follow up.

just a thought: have you enabled both AFP and SMB on your Synology?

no idea how Roon mounts NAS shares, but happens in Mac OS that a share already mounted via, eg, AFP if mounted again via SMB appears to the OS as a “different” one in which case, using “Get Info”, you’ll see “-1” added at the end of its name

It’s only mounted via SMB in the Mac. At this point Roon had entered a phase of just adding and removing non-stop. I have tried rebooting the Mac and the NAS with no improvement. At this point I am just shutting Roon down, until something gets stabilized. I’m really at a loss, as all other aspects of the system computers, network etc. seem stable and seem to cause no issues for anything else in the house.

doesn’t matter: it might have been, sometimes in the past, mounted via AFP too (or some system process might do it sometimes without you being aware. Time Machine maybe?)
look the final “-1” in this share’s “system assigned name” (I only see it there: on my Mac’s desktop there’s no trace of it!): it’s mounted via SMB only and I rebooted this Mac a few minutes ago:

and it might revert to just the “plain one” sometimes in the future

this has caused me issues with both iTunes (missing files) and Audirvana (rescan from scratch) in the past: that’s why, on the NAS I only use for music files, I keep only SMB enabled

do a “Get Info” on your NAS’ share and write down what’s in “Name & Extension” then keep using Roon
next time your issue arises, check again

though, as I said, I’m not at all sure this is causing the issue you have as… looks Roon mounts volumes on its own
(btw: Apple does not want apps to mount volumes privately and, even more, doesn’t want apps to store user/password for doing it! they might, in the future, just block this all)

so let’s wait for @support to come up with better ideas :wink:

Hey @John_Hunt – sorry to hear you’re still having issues here. I don’t see any reason not to disable AFP completely on the Synology, to start.

Moving on,

Would you mind trying to sign in using Roon? This would be using your NAS’s address, and your user name and password. Let us know if that’s any more stable, and if not we can definitely look into this further.


Things seem to have stabilized since switching to the IP address and signing in through Roon. Hopefully things stay that way. Weird that in 1.2 it only worked with local mapping now in 1.3 the reverse seems to be true, but hey! I’ll take it. Thanks for the help!

1 Like

How would one disable afp on one’s NAS? I have a Drobo, set everywhere I can see to mount as smb. But I have the intermittent deleting library issue persisting all the way through 209.

log in as admin and in your NAS’s control panel… this is how it looks on a QNAP: