Itunes Playlists won't import

Core Machine (Operating system/System info/Roon build number)

MacOS Big Sur 11.1. Roon 1.7 build 710

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

not relevant, but xfinity wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

BlueSound Node 2i

Description Of Issue

Itunes playlists don’t import. I followed all the steps in existing article below, but they don’t work.


Hi @Eric_Markowitz,

Can you share screenshots showing:

  • A playlist in iTunes
  • Go to a track from that playlist in Roon, go to click the 3 dots, click View File Info, and share a screenshot of that info
  • The XML file that you exported in Finder / File Explorer

your question doesn’t make sense. “That Playlist in Roon” doesn’t exist because none of the playlists from itunes are in Roon?
also, i did not export an XML - it’s supposes to “suck” in the playlists just like it did my library according to the toggle switch that says “import playlist” which is set to “on”.

Hi @Eric_Markowitz,

From the Music app you need to export the library as an XML file. That XML file needs to be located in the folder that Roon is watching.

While the playlist doesn’t exist in Roon, the track itself should be in Roon and will have this option.

I’ve tried manually exporting both the individual playlists and the entire library as .xml, but that hasn’t worked. let me know if you have any other suggestions.


Hello @Eric_Markowitz, could you please send us some screenshots of the playlist in the watched folder, a screenshot of settings>storage, and verify that the “Import iTunes Playlist” option is enabled for the folder?

Hello @Eric_Markowitz, I noticed that your xml is using a relative path and is in a different folder. Could you please move the file called “iTunes Library.xml” into the iTunes media directory provided that that folder is the watched folder.

OMG! that did the trick. :slight_smile: thank you so much… I wonder why i had to do this manually?@#?!@?#!23

appreciate your help.

all the best,

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.