Jittery playback, audio cuts out every 10-15 seconds

Core Machine (Operating system/System info/Roon build number)

Lenovo Thinkpad X1 Carbon, Intel i5-10210U 1.60GHz, 16GB RAM, Windows 10 Home version 1903, Roon 1.7 build 537

Netgear Orbi RBR50 router, issue persists both on Wifi and on ethernet connection

Linn Sekrit DS

Trying to stream Tidal to the Linn Sekrit, and every 10-15 seconds the music drops for about a second or so. This doesn’t happen when I stream Tidal to the Linn through Linn Kazoo, it only happens when trying to use Roon to stream it. This happens both with locally stored music from the hard drive on the core, and also streaming Roon radio. Any suggestions?

I’m in day 2 of my trial, would love to make this work, but have to fix this issue before committing to using Roon.


Welcome to the forum. Here are some ideas to troubleshoot with. Support would be better able to troubleshoot this, but they are limited on staff until tomorrow. I flagged them for you as well @support


Thanks. This looks like maybe what you call a “dropout”? It happens about every 10 seconds.

By the way, forgot one thing in the setup: the core is connected to an Orbi RBR50 (by ethernet or wifi, the issue persists either way). The Linn Sekrit is connected via ethernet to an Orbi RBS20 satellite, which connects to the RBR50 via Wifi. But they are near each other - on two sides of a wall - and don’t experience these issues when streaming through Linn Kazoo which also relies on the connection between the same router and the same satellite.

Networking can get tricky. I do suggest contacting your ISP to make sure everything is in order and to spec. My internet delivery was sluggish and the ISP tech fixed it in about ten minutes. Something had gone arwy on their end and it changed the “hierarchies” of how my service was being provided. Working great now.

Don’t see how this could be an issue with the ISP - which is Spectrum - because (1) the issue exists when playing music that’s stored on the hard drive of the core, which doesn’t involve the ISP, and (2) the issue doesn’t exist when streaming directly from Tidal via Linn Kazoo (which would involve the ISP) rather than Tidal through Roon. Let me know if I’m missing something. Thanks.

Mine is Spectrum as well. Just a suggestion. Trying to cover all angles.

Thanks for the suggestion. What did you ask Spectrum to do for you? I didn’t think they had it in them to respond to something like this.

My problem was sluggish response across the board, including Roon hiccuping. We ran a couple of tests including internet speed, which should be close to 300mbps for me. He looked at my settings, and the tech said the “hierarchies” were incorrect. I have phone, internet and cable TV services. I’d just ask them to look at my settings and see if everything looked good from their end. It changed my internet refresh rate from sluggish and churning to immediate. The tech I got was really sharp and was a bit older. I called at night, about 1 pm eastern time, which is where to tech was located.

Can you plug the Lenovo into the same satellite? If you’re getting drop-outs on local files I’m going to assume its the wireless link between the Orbi’s.

Next thing to try is remove the satellite and go wireless on the Linn (if you can). It may seem odd why this would work but think of it this way… If you’ve got two wireless devices separated by only a wall they will be shouting at each other so loudly it may be nothing but noise. All that Orbi stuff is designed for maximum coverage which means cranking the power on the radio way up. Two radios shouting at each other at high power isn’t good for performance.

Hello @Dan_Lukas,

Can you please check to see if your System Output zone (the PCs internal speakers) are working as expected? This should help clarify if just the Linn zone is impacted by this issue or if all zones from the Core are affected.

Your Core machine is under spec.

Just tried a few things based on commentary here and here’s what I found:

With the core hardwired into the Orbi satellite instead of the router, I can play from the core to a Sonos Connect that’s also hardwired into that satellite without dropouts. This doesn’t work without dropouts if the core is hardwired into the router, perhaps based on the router to satellite noise as suggested.

But with the core hardwired into the Orbi satellite I’m still getting frequent dropouts playing to the Linn Sekrit. Want to get this to work with the Linn as my understanding is that the Sonos downgrades the digital output quality (is that true?), and also because as a longtime Sonos user before I just upgraded to the Linn, have found Sonos to be a bit unreliable.

Meanwhile, I can play from my laptop directly to the Linn over Linn Kazoo instead of Roon, without getting dropouts when on wifi, not hardwired into either Orbi box. I can also play directly on the core laptop without dropouts when on wifi as well.

So connecting to the satellite rather than the router is helping, but seems insufficient.

Finally, there was a comment just posted that my core laptop is under-spec. That seems odd as it’s a brand new laptop which seems to meet the specs in your FAQ, but please let me know if you think that’s the case.

Thanks in advance for your help.

Hi @Dan_Lukas,

Thanks for the additional info, let me go over a few of your points here:

It looks like it does meet our minimum requirments, here is the CPU Benchmark in case you’re interested.

This issue appears to be related to the amount of “hops” in that case, from the satellite to reach the router.

I have a suggestion that we can test out this theory, if you have an un-managed switch, I would try temporarily connecting both the Core and the Linn to the switch and have the switch hanging off the primary router. That should help keep the amount of hops as short as possible.

Also a few other common aspects which you may not have checked yet:

  1. Is the router firmware up-to-date?
  2. What about the Linn firmware, is that the newest?

Hi, so it seems to be mostly fixed now, but thought I would lay out what happened to see if you have any additional suggestions:

  • Your suggestion to upgrade the Linn firmware fixed the dropouts, that was the main issue and it’s now resolved, so thanks!
  • After upgrading the Linn firmware, the Roon core at first didn’t find the Linn player. I reinstalled the Roon core, and then it found it.
  • After doing that, the Linn would frequently vanish from my system altogether, not only from the Roon core but also from the Linn Kazoo player software as well.
  • After many efforts at rebooting everything and a fair bit of muttered profanity, eventually I noticed that the Roon core had established two separate connections to the Linn: one via Linn Streaming, and another (to the same IP address) through Airplay. I disabled the Airplay connection in your Audio Settings page.
  • Now everything works almost perfectly. In fact, I’m able to play from the core via a wifi connection now, it doesn’t have to be connected via ethernet.
  • The only issue that I’m having now is that if I tee up something on my iPhone as a remote connection to the core, and then my iPhone goes off the wifi network, sometimes the output pauses and has to be restarted. It that typical or would you have any suggestions there?
1 Like

Hi @Dan_Lukas,

Glad to hear that there was some improvements with my suggestions!

When this occurs, are you still outputting to the Linn zone or are you streaming to the iPhone? Having the iPhone disconnect from the network shouldn’t cause playback to pause since the iPhone is just a remote for the Core. Does the network on the Core itself drop out as well?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.