Just getting static from Roon

I bought myself a cheap DAC, the Encore mDSD,
It’s a small USB-dongle with a small headphone output.

I first tried it on my Macbook Air, where, after some fiddling I got it to play (PCM).

I have a DELL OptiPlex 3040 (i5, 8GB RAM SSD) running Ubuntu (desktop) 18.10 with Roon Bridge installed and connected to my Roon Core (on a Dell Precision T3610 / Windows 10).
The Ubuntu machine plays sound just fine through the mDSD in my headphones when testing the device in Audio Settings.

When I try to get sound through Roon I get just static.

I think I’m doing something wrong on a basic level here but can’t figure it out.

How the device looks to Roon Core:
roon1

roon3

Any and all help appreciated, thanks!

That’s quite some Max Sample Rate and Max Bits per Sample. Does the DAC really go that high?

Bits per Sample is probably OK as the DAC can discard the lower bits.

Also a screenshot of what Roon is doing to the signal path may help. Play some music to the DAC and click on the little dot at the bottom next to the track and artist name:

Per the specs: 32-bit/384KHz & DSD256 via USB. I am a complete newbie to this DAC world so please tell me if it looks off.
Here’s what the link included in the packaging leads me to: https://nuoem.com/product-category/brands/encore/

Signal path:
roon5

Here’s some random output from Linux (I just picked it up from the RoPieee threads):

dlundh@dlroon:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0a81:0205 Chesen Electronics Corp. PS/2 Keyboard+Mouse Adapter
Bus 001 Device 002: ID 16d0:09dd MCS 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


dlundh@dlroon:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3234 Analog [ALC3234 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: mDSD [Encore mDSD], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

dlundh@dlroon:~$ cat /proc/asound/card*/stream*
Encore Design Ltd. Encore mDSD at usb-0000:00:14.0-1, high speed : USB Audio

Playback:
  Status: Stop
  Interface 1
    Altset 1
    Format: S32_LE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
    Data packet interval: 125 us
  Interface 1
    Altset 2
    Format: S16_LE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
    Data packet interval: 125 us
  Interface 1
    Altset 3
    Format: SPECIAL
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
    Data packet interval: 125 us
dlundh@dlroon:~$

Hi @Daniel_Lundh,

Can you describe your current networking setup for me, including all networking hardware in use and how your devices are connected?

If you connect this device directly to the Windows 10 Core instead of the RoonBridge device does the same behavior occur?

I use Cat 5e pretty much everywhere.
My incoming router is a Ubiquiti EdgeRouter Pro. This connects to my distribution switch, a HP ProCurve 1810G-24, which connects to a HP ProCurve 2610 where the Dell is connected. I have no problems with my networking gear that I am aware of, there are lots of other things connected to the 2610 but mostly it’s the TV and the Receiver doing network stuff (Netflix, Airplay, yes, wired).
I have an AeroHive AP230 that my main iPad I use to control Roon communicates through.

All music is on a Synology DS1812+ connected to the 1810G-24 with 2 NICs.

I’ll install the driver for the DAC on my Roon Core and see what the results are. It’s 64-bit Windows 10 Pro btw.

roon6
The drivers install fine.

I get 2 new devices:
roon7
Both devices play PCM files fine.

The WASAPI device doesn’t seem to know that it can decode DSD in hardware:

But the ASIO driver thinks it looks good:

When trying to play a DSD file (that converts fine to PCM) through ASIO Native mode just gives static.

So different results than from the Linux machine.

To recap:
Mac & Windows, PCM works fine.

Windows 10+ASIO driver says Native DSD support but gives static.

On Mac it isn’t recognised as having native DSD.

Linux: Static, no matter what type of file I try to play.

Thanks for the information here, @Daniel_Lundh,

I noticed that the product page doesn’t mention Linux support for this device. I’m going to discuss this with our technical team during our meeting this week, but it may be the case that this is not a device that supports Linux.

So we can have some additional information for the meeting, I was hoping to enable diagnostics on your account so the team could take a look at the diagnostics report. Before doing so, could you reproduce the issue once more and make a note of the time that you start playback as well as the content you’re playing. Report this information back here and then I will enable diagnostics for the team.

Thanks!

I’ll reproduce it today and update here when I do, I went with Linux because I want a headless machine I can tuck away out of sight. I’ve read up on Linux support and found this:
"But the Encore mDSD does work with Ubuntu 16.04+

It is recognized by recent kernels and I’ve been able to get it to play DSD files using MPD (0.20.2). However, I had to set: dop “yes” within the .mpdconf in order for DSD files to work, so it’s limited to DSD128 files as a maximum. That might just be a kernel module limitation with the XMOS chip in the mDSD. Maybe future kernels will allow native DSD support."

Also of note, Linux itself does play (PCM I guess) system sounds via the Encore mDSD.

I’ll try DoP setting on Linux/Windows and see what that gives me.

Just now I tried on the Roon Core:
Everything Counts by Depeche Mode in DSD64. In DoP mode i get static but at a low volume. In Native mode I get loud static but music in the background and the Encore mDSD LED changes to blue (indicating DSD decoding). And of course going over to convert to PCM makes everything work fine.

Next up Linux!

And I tried Linux now.
And it works?!
Both PCM (FLAC file) and DSD, Everything Counts by Depeche Mode (same file as on Windows) via DoP.
When trying to change volume in Roon it returns to static but pegging it at 100% gives clear audio and I can change volume with the buttons on the mDSD itself.

This whole thing is really mysterious to me.

You need 100% fixed volume for some dacs to work especially with dsd on Linux. My Arcam irdac ii did the same if I altered the voulme. You need to use DSP volume if you need to make adjustments or the devices voulme unless the device allows Roon to change it, which is pretty limited in supported dacs.

1 Like

Hi @Daniel_Lundh,

As Simon mentioned above, fixed volume may be the solution here since it works with 100% volume. You can set this in Device Setup.

Yes, the suggestion from @Simon_Arnold3 works for me.

Whew, was I just supposed to know this?

Anyway, thanks for your time and effort!

1 Like

Don’t worry, these things catch most of us once in a while not something you should have known really. Some DACs will work nicely and let them be controlled volume wise by other software but on Linux support it is not often that great for DACs, also there are only a few in which Roon can control the actual device preamp volume I think and they are the Roon Ready ones.

1 Like