Just installed Roon 1.2 on a Synology DS716+ NAS

I was just curious if it could work. I tried to run the easy install script in a ssh session on a Synology DS716+ (4Core-x64 CPU) and got a error message first:

sudo ./check.sh 

Checking to see if RoonServer can run on this machine 

    Checking for Binary Compatibility                            [   OK   ]
    Checking for ALSA Libraries                                  [ FAILED ]
    Checking for ffmpeg or avconv                                [   OK   ]
    Checking for the mount.cifs command                          [   OK   ]
    Testing ulimit -n 8192                                       [   OK   ]


These issues must be addressed before RoonServer will run on this machine.

For more information on how to address this, see:


The Synology had ipkg installed and also alas-lib.

I just tried to download the whole package and ran the start.sh script and in general it seems to work:

sudo ./start.sh

I could login from my Mac to the RoonServer running on a Synology NAS and add a local music folder. It also plays nicely to my Mac or a Hifiberry DAC+ equipped Raspberry Pi which is currently running SqueezeLite.
Tidal does not seem to work in this constellation.
But in general this gives me hope that in the future I don’t need to keep my MacMini running 24/7 to be able to start my music playback.

Thanks for the Linux packages!

EDIT: Tidal might work, but I can’t test it. I thought I read an error in the settings, but I seems to be fine (but as I said “untested”). :slight_smile:


Hi Christopher,

I’ve done this as well and it worked like a charm, up to the moment when my Synology DS1813+ stopped executing other packages! The reason is that installing it this way the Roon database will be located in the root directory, and this partition is too small for my database.

So be careful!

The easy install provided from Roon does not work. First thing is that it refuses because ALSA lib is missing. I’ve found a workaround for this but struggled with other issues, first /etc/init.d doesn’t exist, and the script failed.

Hope I can manage but it would be great if Roon could provide an easy install script that works on Synology DSM - because up to that moment it was great, including Tidal. It’s just a matter that it’s installed properly (no database in root) and that it’s able to run on startup.


Thank you for the info NOA.

I am also currently still investing and I am looking into building a spk file for installation. But I never did this before. But I am making progress… :slight_smile:

Maybe it would be possible to symlink the Root database folder to a different location? I just tried it with a very small music library…


1 Like

as @evand wrote in a different post in this section.
It also works to add the following line at the beginning in the start.sh script:

export ROON_DATAROOT=/path/to/database/directory

This would solve the issue with the small root partition.

EDIT: forgot the “export” in the line. Corrected now…


Yes will try and eager to learn your progress with the SPK package.
Me too - no experience with Linux at all but always interested in learing by doing.

Your screenshot and the DSM language tells me you are somewhere around in Germany as well…

That’s Great!!

I tried another way to install RoonServer to Docker image based tutum / ubuntu on my DS1515+ .
I install some packages via apt commands and I got messages …
Checking to see if RoonServer can run on this machine

Checking for Binary Compatibility                            [   OK   ]
Checking for ALSA Libraries                                  [   OK   ]
Checking for ffmpeg or avconv                                [   OK   ]
Checking for the mount.cifs command                          [   OK   ]
Testing ulimit -n 8192                                       [   OK   ]

root@tutum-ubuntu1:/opt/RoonServer# ROON_DATAROOT=/var/roon ./start.sh
( http://kb.roonlabs.com/LinuxInstall is helpful, Thank you . )

Probably, I can install and run RoonServer .
On the other hand, I can neither find music files on /var/roon/music nor
I cannot connect to this RoonServer .
( I can connect Win10 Roon Core from RoonRemote my Mac , android, and iOS )

Do I have to set port mapping up or another seting is needed ?

Could you tell if you got the ALSA Libraries installed via apt commands, and if yes, how?

I’m trying to do the same, but I keep getting failed for the Testing ulimit -n 8192

I’ve tried everything I found on google to raise the ulimit, but nothing seems to work.

Did anyone else have this problem?

I using a DS1515+ running DSM 6.0

In my case, I add repository for media lib .
root@tutum-ubuntu1:/opt/RoonServe# add-apt-repository ppa:mc3man/trusty-media
and then
root@tutum-ubuntu1:/opt/RoonServe# apt-get update
root@tutum-ubuntu1:/opt/RoonServe# apt install ffmpeg
root@tutum-ubuntu1:/opt/RoonServe# apt install libasound2

If you cannot use add-apt-repository command,
You will try
root@tutum-ubuntu1:/opt/RoonServe#apt-get install software-properties-common

How about this setting in ?
Docker >> Container >> Edit, Basic Option Tab
I can change ulimit setting , when the box is checked .

You’re a genius. That worked. I see there is now a pkg that can be installed, so I think I’ll stop my docker tinkering.


Please suggest whether Roon Server can be installed on DS415play?
or I must have 64 bit box?

I would greatly appreciate if you could share detailed instructions how you managed to make it work !

Thank you !

If it’s not 64 bit it won’t run… - the Roon packages are 64 bit.