Keep losing wifi connection to Roon Server [Resolved]

I connect to Roon Server via both wifi and Ethernet. I never lose the Ethernet connection. The wifi connections, through both a Windows 10 PC and Android phones, keeps getting broken, even though other apps on the phones and PC are able to see the network. Rebooting Roon Server fixes this.

Thank you for the post @John_Gallup and sharing your feedback with us. Appreciated!

Moving forward, just to make sure I am understanding your report correctly. When the device hosting RoonServer is making use of an ethernet connection your remote devices function as expected but if the device hosting RoonServer makes use of a Wifi connection the remotes struggle to connect, yes?

Are you planning to switch over to Wifi on the Roon core and not make use of the ethernet connection? Can you provide me with the details of your setup using this link as guide? Having the details of your network configuration/topology and all the devices involved would be help as well.



Sorry I didn’t make myself clear. The RoonServer device (an Intel NUC) is always connected by Ethernet. I can access RoonServer reliably from other Ethernet-connected devices, but have a problem with Android wireless connections (a Galaxy S8 and a tablet)


Hi @John_Gallup ---- Thank you for the clarification, I appreciate the insight :+1:

Moving forward, would you kindly please provide the details of your setup/network as mentioned in my previous so we have a better sense of what your setup looks like/the gear you are currently working with.

Additionally …

  • My assumption is that the mentioned Win10 PC is the device making use of an ethernet connection, if this device is acting as an active remote (LAN connection) and the Android phones are trying to connect does the Win10 PC remain in stable contact with your core?

  • You mentioned that rebooting the RoonServer temporarily solves this behavior. How long do the remotes typically remain in contact with the core?

  • While this may seem elementary, during your troubleshooting of this behavior have you tried rebooting all relevant device (i.e core machine, remotes, and networking hardware)?


Problem solved, Eric. It was a wifi range extender that was confusing the Android devices. Thanks for your help.

1 Like