KEF LS50 Wireless Connection

Roon is streaming Tidal to my LS50Ws using a Dell laptop as the core. The only way I’ve achieved the lossless signal path shown here is to select “Roon Tested (via KEF streaming),” presumably, because this bypasses any Windows processing. However, Roon presents this option only when the core is connected to the master LS50W by both USB and ethernet cables. The “Roon Tested” output option necessary for the lossless path disappears when using only one or the other. Is there a reason both are actually necessary? Or, is there a setting that will get it down to just one of them?

I moved this to the Kef area maybe @Ben_Hagens can chime in here

KEF Streaming is the WiFi/networked aspect and should have nothing to do with USB. Have you set up LS50W to your actual network, because it reads like you’re connecting it directly to the Dell by Ethernet?

Also, when were the LS50Ws purchased and have you ever performed a firmware update for them?

The firmware is current. Yes… The KEFs are on my wifi network as was the KEF Control app. If the KEF app was reliable and didn’t drop-out every single time, I could avoid Roon altogether; I no longer use the KEF Control app at all. So, again, the only way I’ve achieved a lossless signal path is to enable the “Roon Tested” output option; but, that option is present on the set-up screen only when the core is hardwired both by USB and Ethernet cable to the KEF. Nonetheless, while playing, the KEFs are in wifi mode, though not, I think, actually using wifi; because, if either the USB or ethernet cable is unplugged during playback, everything stops.

Taking a step back, how are you aiming to connect preferably? Via USB? I don’t have a first generation LS50W to hand, but if you enable the USB option in Roon, and go into the device settings and turn on Exclusive mode:

That will. bypass WASAPI and you should get lossless LS50W playback via USB then.

If what you’re wanting to do is actually play via network, then a description of your home network would be useful - model of router, distance to Core and LS50W, number and types of walls in-between, whether using mesh or extenders, what band are you using, if it’s a combined SSID etc, being as descriptive as possible.

If you plug the Ethernet into something, then the wired connection of LS50W to the network will take precedence over wifi - and it’s obviously connecting to a network of some description because it’s showing an IP address. However, I see that this is This is an error address (this is a standard error address, not an LS50W specific one) where connection to a DHCP host isn’t happening, so devices give themselves an IP in this range to allow communication with other devices. For reference, home network IP addresses tend to be What I’m trying to get at here is why KEF Streaming isn’t showing when connected to the home network normally.

I don’t mind hardwiring the core to the LS50s. They are located on the main floor of the house while the router (Qualcomm QCA61x4A 802.11ac, 5GHz combined SSID, non-mesh, no extenders) is in the basement. Both the core and the LS50s are connected to the home network; yet, there’s still no KEF streaming option without both the USB and ethernet cable connecting them. The only IP address I find is The core machine is in exclusive mode; but, I see no option in Roon for USB mode.

I’m looking at the first image for that IP address - under where it says ‘KEF Streaming.’ When you connect your ethernet cable between LS50W and your Dell, your LS50W is no longer connecting to your WiFi network. So that’s the first thing to eliminate.

The USB connection between your Core and LS50W is the other one in your pic, where it says WASAPI afterwards. You always see that when LS50W is on and connected by USB only, right? Enable that, then you should be able to go into Roon’s Device Settings and find exclusive mode.

I do have some general router advice which may go some way to explaining your LS50W network problems - basements are not great for routers, and especially 5GHz, so I imagine that LS50W just isn’t getting the bandwidth it needs. I had the same personally back when I was in the U.K., except the router was in a cupboard under the stairs with the hot water boiler - stuck in an enclosed space with a giant metal thing next to it just absorbing so much of the signal. 5GHz has really short range as it is, and obstructions like walls really cut the bandwidth down significantly. Even worse when it’s concrete or reinforced concrete (or anything with metal, really). Think of WiFi like sound - the further away from the source of sound you go, the quieter it gets, and same again when you put that sound source in another room. Combined SSID is also a bit of a mare as well, as every manufacturer does it different. Some are really good at switching between 5GHz and 2.4GHz, others have various settings where it defaults to preferring 5GHz even when it’s really weak but still just about possible to connect. But moving the router out of the basement, if possible, is a good first step. You should see your overall network performance improve, actually. If not, then my next port of call would be to separate the SSIDs and run LS50W on the 2.4GHz band. Lower bandwidth, but longer range and is somewhat less impacted by obstructions. You may not see this impact as much with web browsing or even with Netflix and YouTube, because of how they download and buffer - streaming music is actually a lot more intensive than people think, even though the bit rate of audio is relatively low.

The kids do their gaming in the basement; so, I’ll let the router remain there. My only priority is sound quality, no matter what configuration I must implement.

Yes, WASAPI is always there when using USB only; and Roon was, indeed, in exclusive mode.

I am still unclear about, 1) why the KEF streaming mode does not appear unless both the USB and ethernet cables are connected. If I’m in KEF streaming, and the LS50 automatically switches to wifi, is it possible that the signal is passing through one of the hard lines nonetheless? If not, and it’s actually using only the wifi signal, why on earth can Roon not find the KEF streaming option without those hard lines? And, 2) since using either the KEF streaming option (soeaker in wifi mode), or the WASAPI option (soeaker in PC mode), Roon reports a lossless signal, why does the sound seem slightly better when using the former?

I’ll answer 2) first - it’s subjective. A lot of people seem to consider the USB connection on LS50W to be the best sounding.

For part 1, can only speculate as it’s definitely not an intended setup case, how you have things wired. It’s actually pretty similar it seems to the firmware update procedure, where the computer and LS50W must be on the same network, and you need the USB connected simultaneously. In your case here, your Dell and LS50W have created their own little ‘sub-network’ (hence the 169.254.x.x IP address) so are communicating that way. But in this state, LS50W is definitely not on your home network, which would be the intended setup case.

I would maybe try, just for troubleshooting sake - not permanent, moving the LS50Ws downstairs where the router is, making sure it’s connected to the router either wirelessly or wired, and that your Dell is definitely connected to the same network/SSID. No USB, no ethernet to the Dell from LS50W.