KEF LS50 Wireless: DSD Conversion


Core Machine (Operating system/System info/Roon build number)

Intel NUC ( NUC5i5MYHE)
Version 1.6 (build 416) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Gigabit internet connection, Google Wi-Fi (router), R.O.C.K. connection = wired, KEF LS50 connection = wired, Cat 5e cables

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KF LS50 Wireless via ethernet

Description Of Issue

When DSD files are played, there’s no sound. Standard and high resolution PCM play well but I’ve tried this with numerous albums and I’m wondering if I need to change some settings so the LS50 will play these albums?

Hi @Thomas_Becker,

If you try to play these DSD files to another endpoint or to the ROCK’s HDMI output (connected to a TV), do you still experience this behavior? Have you tried multiple DSD files or just the Prince of Darkness one listed in your screenshot? You can grab a few other DSD sample files from the 2L Test Bench if you only have that current one to test.

I tried +/- 30 DSD files including files purchased from

I set up a Macbook Air as an end point and the files play.

Hi @Thomas_Becker,

Thanks for confirming with the other DSD files. I requested that our hardware team attempt to reproduce this behavior with the LS50s we have in the lab and they have been unable to do so, DSD64 down-sampled is playing as expected.

I have a few other thoughts here:

  1. Can you verify to make sure you’re using the newest firmware on your LS50s?
  2. Is the behavior the same if you set your Max Sample Rate (PCM) to 96kHz?
  • LS50w Firmware is current

I set the max sample rate for the LS50 end point to 96kHz… now DSD files are converting and playing.

Weird but thank you for the fix.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.