KEF LS50 Wireless II and Coax Input with Mutec USB

I have been using an Mutec +3 USB for several years in my main system. USB in and AES out to my DAC. Mutec REF10 as external master.

I am trying out a new pair of KEF LS50W-ll’s and want to feed their coax input from the Mutec until Roon Certification is completed. I thought that it would be as simple as disconnecting the AES cable and then hooking up the coax to the KEF but I am getting no audio output. I have not changed any settings on the Mutec. I have chosen coax as the KEF input and switched the Roon app to point to my Audiolinux Roon Endpoint which feeds the Mutec.

The Lock LED MAIN REF is on, as is the LOCK RE-CLK REF and Audio LED.
The top three REFERENCE lights are on.
For MODE I have EXTERN and Re-CLK

Any ideas?

Ok. It turned out to be an ID10T error.

The LS50s have an RCA subwoofer jack also. I had the coax cable plugged into the wrong jack!

The coax sounds excellent using my Audiolinux/Mutec USB front end. Looking forward to hearing the Roon Ready KEF implementation.

I’d imagine that will be really hard to improve on. If RAAT ends up sounding better than that it will be more than fabulous… :smiley:

1 Like