KEF LS50 Wireless Volume Syncing issues

@support and other LS50W owners.

I am having intermittent issues with the volume shown in Roon not always being in sync with the true volume of the speakers. It happens when I use the hardware remote rather than the volume control in the KEF Control or Roon apps.

If I use the KEF Control app or the Roon app the volumes stay in sync as expected.

However, regularly when I adjust the volume with the supplied KEF hardware remote, the volume value in Roon does not change. The change is reflected in the volume coming out of the speakers and within the KEF Control app though.

For example, if the volume is as 50 and is then turned down to 30 with the physical remote, the volume change may not be reflected within Roon. If I tried to lower the volume in Roon in this example, the volume in Roon will change from 50 to 49 causing the true volume to jump up from 30 to 49 which is very jarring.

Strangely, this problem is not consistent. Sometimes it works fine, other times it is out of sync as described above.

Is there anything I can do to solve this? I would like to use the physical remote and refer to Roon to see the volume level but currently I can’t trust it.

I am running the latest version of Roon on a Mac Mini connected to the router via ethernet and the LS50w are connected to the network using wifi. I would prefer to keep this configuration without connecting the speakers via ethernet as I can only do this via a homeplug.

Thanks in advance of any advice.

Hello @inbox4,

Two questions before we get started with the diagnostic process:

A) Have you checked that your LS50 Wireless firmware is up to date?

B) Have you ever noticed that volume commands being sent from Roon were being ignored by the device? Or is this issue limited to the KEF speaker not updating Roon about the status of its current volume?

The next time this issue occurs, please grab a set of Roon logs from your Roon Core and post the file-sharing link in this thread.

It would be helpful if you could make note of the local time that the issue occurred so that we can focus on the time-frame around the troublesome behavior.



Apologies for taking a while to reply.

I’m unsure how to attach the logs, I’d prefer not to share the file publicly. How do i share the file privately with just @support?

I am continuing to have the issue and will answer the above questions when I supply the file.

Thanks and regards

Hi @inbox4,

You can private message links by clicking on user’s names (such as John’s above) and clicking on “Message”. I will send a private message to you shortly and you can let us know the link to the log files there, thanks!

Hi @john

I have sent the log files with timestamps to @noris. The answers to your questions are:

  1. Yes, the LS50ws are running KEF’s latest firmware.

  2. The volume commands sent by Roon are always received by the KEFs. The issue is limited to the speakers not updating Roon. It would seem that if I restart the Mac running the core it solves the issue. However, I like to leave the Mac on. The problem seems to occur from the second listening session onwards. I would like to get to a position where I can leave the Mac on indefintately and have the volume controls always work in sync. I haven’t worked out at which point or why the sync breaks.

Thanks and regards.

1 Like

Hi @inbox4,

Thank you for sending those log files over, I have created a ticket and have passed them to the technical team for closer inspection.

Hi @noris,

Could you chase an update on this issue for me please? I’ve not heard anything and the issue intermittently persists.


Hi @inbox4,

I spoke to the technical team regarding the behavior you reported, and we have been unable to reproduce on two sets of LS50 speakers.

Is there any additional information you can share with regard of a rough timeline of when this issue starts occurring?

Does it only happen after Roon is running for a few days? Does it only happen after playing certain types of content? Does it happen when you switch between multiple zones?

Any additional info that you can share that would help make this reproducible in the lab would be very helpful.

A post was split to a new topic: LS50W USB Volume Issue

I don’t have the LS50s anymore.

I didn’t get to the bottom of this issue though.

I have a different core now (Intel NUC) and a NAD M10. I still find the volume numbers are often out of sync on this completely new system. It is only ever one or two volume units out so I don’t get the big discrepancies and then the big jump in volume but I don’t understand how they can get out of sync.

Good luck resolving.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.