KEF LS50Wii - Problems with going back and forth between Qobuz and Tidal

I have brand new LS50Wii speakers - purchased about 10 days ago. This is not strictly a Roon issue (waiting for Roon Readiness!), but I’m hoping I’m allowed to get your thoughts on an issue with the speakers.

Today, while using KEF Connect, I was going back and forth between my Qobuz and Tidal accounts, and when I played a number of different 24/192 tracks on Qobuz, for the first time the playback would pause repeatedly and then continue while (I assume) the cache caught up with the playback. This happened with any number of 24/192 tracks.

This is only the third time I’m using these new speakers, but the other two times, I had absolutely no problems playing such tracks. This is the first time, however, I went back and forth with Tidal.

So, I then thought I’d see if a hard-wired Ethernet connection would improve the LS50ii performance - I have a pair of LSX speakers elsewhere in the house connected to my Ethernet network and they work with 24/192 files flawlessly.

When I connected the Ethernet cable to the master LS50ii speaker, however, it rendered the speaker set unrecognized by the KEF Connect application. I could see no source (Coax/Bluetooth/etc.) that would direct the speaker to the Ethernet source.

So, two questions:

  1. Are you aware of any issues with playing 24/192 files when going back and forth between Qobuz and Tidal? My uninformed sense is that the streaming pipe tightens for Tidal (less bandwidth needed) and then doesn’t expand back for the bandwidth needed for 24/192 files. I know that’s wholly unscientific, but that’s what it seems like. (I should also note that when I restarted the speakers and just played Qobuz exclusively, there was no problem at all playing 24/192 files, so it seems like it’s the going back and forth is causing the issues).

  2. Is there any way to feed my LS50ii speakers via Ethernet and make that the primary source rather than WiFI? Would I need to start my setup from scratch?

Thanks for your help.

When you connect LS50WII into your network with an Ethernet cable, that automatically takes precedence over WiFi.

I’ll have a play with my set going between Qobuz and Tidal. Just to confirm - Tidal within the app, or switching with Tidal Connect and the KEF Connect app for Qobuz?

  1. Plugging in the Ethernet cable to the speaker just results in the KEF Connect app saying it can’t find the speakers. Resetting the speakers didn’t help. Getting my flashing lights in the Ethernet jack on the back of the speaker.

Also, I’m in cable mode with an interconnection between the two LS50s.

If it matters, I’m plugging cable into an Ethernet wall outlet, not directly to my Verizon router or my switch in my basement (but that’s the same setup that works great for my LSXs).

  1. Switching back and forth only within KEF Connect app, not using Tidal’s app.

Would it be much of a trouble to try hard wiring it into your router directly, or in the same position as your LSX pair, just to rule out something between the panel and your router being an issue? May seem superfluous to try as you’re getting the green/orange lights, but might be worth doing.

Ben - moved speakers to my router location, plugged from router to network input on primary speaker and and had same problem. Reset speaker without Ethernet plugged in and recognition of speaker ended when I plugged in Ethernet.

Same occurred when I plugged Ethernet into different wall plate.

Went back and forth to Qobuz and tidal and couldn’t replicate that issue, with 24/192 playing fine (good news, hopefully) but still can’t get speakers to give over to Ethernet.

Didn’t try the wall plate where LSX is located and can try tomorrow but I don’t expect that to resolve the issue.

And, other devices working fine wired into the wall outlet that didn’t work for the KEFs.

Hi Stuart,

Just had a quick chat with one of my colleagues - can you replicate the ethernet issue, and straight away go into settings in the Connect app and send a log with a description (I think you can pretty much copy/paste most of what you’ve already written in here). That will then go to our CS department and they can have a better look into it.

Something else to quickly try before sending a log - before plugging in the ethernet cable, ‘forget’ the speaker in the app. Plug it in - does your speaker stay in the second list, or disappear? And are you using iOS or Android (colleague’s question).

Will do today - thanks.

Sent log and recap to your CS department today - BTW, if I didn’t mention, I use iOS apps.

Thanks for your help.

Problem solved. And I am embarrassed.

The problem was that, while my LS50iis were indeed connected to my Verizon network via Ethernet, my KSF Connect app was…that’s right, on my Eero mesh network.

Apologies for your taking the time to think this through - you can’t save me from my own stupidity…


Glad to hear you’re good! Not being recognised over Ethernet was a bit of a head scratcher, and being a home environment, having a second network didn’t even occur to me!

1 Like