Kef LS50w's not appearing

Core Machine (Operating system/System info/Roon build number)
Roon Core on a NUC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
KEF LS50w.

Description Of Issue
Just setup a Roon Core on a NUC and for some reason my KEF LS50w’s do not appear as a Roon device I can enable want to get some pointers on how to fix?

(The KEFs showed up and worked great when I was using my Mac as the player and core)

Which model of LS50w are these? Have you used them with Roon before? If they are the original, released a few years ago, have you checked that the KEF firmware is up to date? You seem to have changed your configuration since they last worked, so please describe it as asked in the Support submission template.

If they are the new LS50w II models released in September, they haven’t completed Roon Ready certification yet, and so Roon blocks them as unsupported.

Though they still should be recognised by Roon and displayed in settings, but they would have the pink “Uncertified” banner and cannot be enabled for use.

@support - Is it possible this configuration change after Sept. 21 threw him into the unsupported device category, even though he was grandfathered in on his Mac?

Hi @Joe_Timmons,

Can you please share a screenshot of your Roon Settings -> Audio tab?
Is there any change in behavior if you try to reboot your ROCK or networking gear?
Do you have the LS50 II or original?