KEF LSX a Nightmare on Roon Network

Core Machine (Operating system/System info/Roon build number)

Mac OSX 10.14.6
Roon build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Macbook core via ethernet
LSX via wifi from Netgear RA80

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

N/a

Description Of Issue

  1. To play over LSX directly i have to start a track playing to them over airplay. Only after that does LSX direct come up as a zone option in Roon.

  2. Every few tracks it stops at the start of the next track. It loads the track but I need to press play to continue playing.

Is this Roon or KEF’s issue?

Thanks

Hello @Hugo_Sharp,

Do you experience this issue with other playback zones on your network? If the KEF LSX is the only device exhibiting this behavior, it would appear that your Roon installation and configuration are in good shape.

Have you updated your KEF LSX to the latest available firmware? Do they exhibit this behavior when connected using a wired network connection?

-John

1 Like

Hi John, yes all up to date and no issues with any other zone. My annoyance is definitely with KEF, it’s been the only trouble child with Roon. It’s fully cabled via ethernet now.

Do you use the KEF’s with other inputs also? because:

Using AirPlay first sounds like a hack to make the KEF’s switch input.

Hi

I use the KEF LSX every day in my Roon system without any problems. I can also use several zones via Airplay 2 (eg KEF LSX and Bluesound).
Works with me via LAN and WiFi.
For the LSX a new firmware came out. This should certainly be updated.

Regards,
Markus

Hi @Hugo_Sharp,

Have you tried factory resetting your LSX speakers yet? I have seen a few reports when factory resetting KEF speakers helped sort out some intermittent issues, it’s worth a try if the behavior is still the same since connecting them via Ethernet.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.