KEF LSX Mismatched IP Addresses

Firmware 1.0 - build 183
Roon 1.7 - build 521

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear R6399v2 router
both WiFi and wired. I’m using wired

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Firmware p20.4101909240.105243

Description Of Issue

Roon shows the KEF’s as Roon Test, connected via KEF streaming with IP
KEF Control shows speakers with IP

Router shows as another device which I believe is correct
Router does not show as device, either wired or Wifi

Can ping with success

How can I delete KEF as an audio device within Roon and set it up again. Altneratively is there a way for me to manually configure the correct IP address?

A bit more info.

Wired version worked well until yesterday. No upgrades of anything.

Have second Roon Zone with same speaker but on WiFi through Apple Airplay.
IP is Both Roon and KEF show the same IP. Music plays.

If you want to lock a device onto a particular IP address you can use the MAC address of the device if you know how to find it. Input the MAC address into your router or cable modem and tie it to the IP address you want and the reboot the device and it should come up with the desired IP address. I do that with all my audio devices as I don’t want them jumping around when they get rebooted.

Hi @Scott_Magill,

Based on the comment here, it sounds like the speakers are working properly, just that they had the wrong IP assigned to them when you initially made you post? Was the behavior the same following a Core reboot?

If you wish to have devices on the network use the same IP address each time, then setting up a Reserved IP based on MAC address is a solution. Do let me know if that helps!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.