KEF LSX "Roon lost control of audio device"

Core Machine (Operating system/System info/Roon build number)

MacMini (late 2014) 2.8 Ghz Catalina (10.15.1) 8GB RAM
Roon 1.7 (build 511)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi RBR50

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KEF LSX connected to ORBI satellite via ethernet cable

Description Of Issue

I just moved my library to this mac mini and when I attempt to play music via the LSX’s via Roon I receive notice that “roon lost control of audio device.” I can control the volume and switch to Wifi/internet via Roon but it will not play. LSX’s work fine via TV optical output hookup that is linked to my macmini.

Did you make sure to use the latest firmware for the LSX? I had the same issue, but after the upgrade it was gone. Latest firmware version is 4.1.

Just checked. It’s 4.1 as well. I had the ROON server setup to another mac mini in the Den and didn’t encounter the problem until I moved the server to my mac mini in the living room today.

Hi @Timothy_Lamb,

How was the Mac Mini in the Den connected to the network vs the current Core? Have you tried rebooting the Core and KEFs? If you switch back to the previous Mac Mini as a test, are you able to play content as expected?

Hi Noris - The Den Mac Mini was connected to my wifi (Orbi RB50) router via ethernet. The LSX’s were then connected to a satellite via ethernet. Now the Core is being run on my Living room Mac Mini (I keep the library on en external HDD) that is connected to the same satellite as the lsx’s. I can control the volume and switch the LSX’s to ethernet connection (white light on the LSX) but when I press play I get the message that Roon lost control of the audio device. I’ve not tried moving the core back to the Den as while I’m sure that would work, I spend more time in the living room listening to music and it made no sense to have both Macmini’s running.

I can run them via toslink connected to my TV but it runs less than lossless.


Hi @Timothy_Lamb,

Are you using the latest Orbi firmware for both router and satellite?

Just checked. Yes, it’s up to date.

I’ve moved my mac mini HDMI to the TV’s Toslink output to ‘exclusive mode’ in Roon so at least it’s now avoiding the OS mixer and I now don’t have to switch inputs so I’ll just use this for now on.

1 Like

My LSX still have this issue. 6 months now. On latest firmware. If wanting to use LSX with Roon i’d say don’t buy them. Look at an alternative. 50% of the time i can only see them as an Airplay endpoint. When i do get them as a full endpoint Roon will lose control of them within a few track changes. If i pause prior i don’t lose them but that’s getting tiresome.

I gave up on streaming directly to the LSX long time ago… I’m using an old RPi II with a hifiberry hat I still had lying around with an optical connection to the LSX.
Much more reliable now.

1 Like

A post was split to a new topic: KEF LSX - Playback error until Airplay is used

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.