KEF volume jumps to 100 on speaker when connected over ethernet [under investigation]

We think we have a fix, and I need to test it. If it’s good, it will be in the next release.


on the side note…

would be great to be able to set volume limit (option).
Recently my finger slipped and volume ended up on 80. Oh my, oh my, that wasn’t pleasant at all!

It’s a good idea… and that’s all I’m saying about that :zipper_mouth_face:



Well, it appears the fix may not have come soon enough for me. Another inadvertent UPnP bridge blast at full volume seems to have left a lasting ‘hiss’ (proportional with volume) emanating from the Uniti 2. No other source/amplifier available here to check if it’s a problem with my PMC speakers or the Uniti 2. Great. Juuuuuuuust great.

oh lord!!! :frowning:

Anyone know when the fix for this issue is being released?
Thanks in advance.

Real soon :wink:

1 Like

Roon 1.4 was just released, with what should be a fix for this issue for the LS50W speakers used directly through Roon. I don’t think that specific fix will address your situation, using the SonicTransporter UPnP bridge etc.

We also added a feature to allow user-settable volume safety and comfort limits to specific zones in Roon, which might solve your problem. Try these steps from a Mac or Windows computer:

  1. Select the zone you want to set volume limits on, as if you were going to play music to it
  2. Right click on the line art for the zone, in the lower right corner of the screen, just to the left of the volume thing
  3. Select “Zone Settings”
  4. Click “SET VOLUME LIMITS” towards the bottom of the pop-up window
  5. Set a “safety limit” at some value that you are confident won’t damage your hardware

I believe similar steps will work on a mobile device, but I don’t know exactly what they might be.

Our ability to support the UPnP bridge on the SonicTransporter and MicroRendu type hardware from Sonore is somewhat limited, you may need to contact Sonore support for more help with this.

For everyone else with KEF LS50W hardware, let us know if you have any problems with either the volume safety limits or the fix for the automatically coming up at max volume thing.

Sorry if this is a dumb question, but if I run Roon on an iPad-controlled Sonictransporter (Sonicorbiter OS, i.e. Linux based), can I do these steps, or was your ‘mobile device’ comment directed at this? Am I going to need to download Roon onto my Mac Mini to access my zone and make this change such that the ST can then benefit?

I really wish I’d steered clear of the UPnP bridge idea that Andrew at SMG suggested. He wasn’t to know this volume issue was lurking in the detail, but I could’ve done without blasting my amplifier section and speakers at 100/100 on the volume scale. No issues with Roon until then.

I checked, it’s the same on an iPad as on a desktop, except that instead of right clicking on the line art one needs to long-press on the line art instead. Alternately, you can get to the zone settings by tapping to go into volume control, then tapping the little icon with two gears at the top right of the volume pop-up.

You have my sympathy for UPnP bugs, this sort of thing is basically why Roon proper doesn’t support UPnP.

My issue is fixed with version 1.4 :+1:

Great. Thanks for checking.
I’ll follow this procedure as soon as I resubscribe (I’d given Roon a wide berth as a result of ‘volumegate’ !).

1 Like

Yes, works great! thanks a lot.


I just experienced the problem with my brand new pair of LS50W…
My Roon installation is up to date (1.4 b294).

First I was listening music on my KEF (Core is installed on my Windows 10 computer). I stopped playback for some time (keeping Roon open), so the LS50W went in sleep mode. Later I turned them on again and after a few seconds, the audio zone reappeared in Roon with volume set to 100 (despite the limits that I set up) !

Seems like your fix is not working or not in every case.

Yep… it’s still happening to my Kefs since V1.4. It’s quite rare, but it does happen. Mine jumps to 96ish, even though my upper limit is set to 80 and my ‘comfort’ level is set to 70.

2 posts were split to a new topic: Default volume to 100 - Naim Uniti 2

Hi @AdZero / @Dan_Brown / @Dave_Woollard ---- Thank you all for chiming in and sharing your feedback with us in regard to the this observation you have made with your KEF speakers.

Moving forward, we are going to be setting up some additional testing with our tech team to see if can try to understand why this behavior is still occurring with LS50s. Once I get some feedback from the team I will be sure to follow up in a timely manor to provide an update.


Looking back through these posts and re-reading the Thread title, I should point out, if it helps, that my KEFs are connected via Wi-Fi, not ethernet.

There’s a bit of a ‘safety net’ I can recommend for people until the fault gets fixed.

Use Volume Levelling of, say, -23 LUFS. This definitely takes the ‘heat’ out of loud tracks and I’m sure has saved my drivers when I did a zone transfer from my Sonos once!

Thanks for getting back to us @Eric! Good luck finding the problem!

1 Like

Eric is there a fix to this? I’ve had the volume jump to 100% on my LS50W about 4 times since moving to Roon v1.8.

Given that the last post before yours in this thread was from 3 years ago, it is probable that a fix has been implemented.

It is probably better for you to open a fresh Support case in the Support category of the forum, so that Support can pull logs from your system. Please give full details of your Roon and networking setup as described here: