Korg DS-DAC-10R, No native DSD playback strategy

Hi @spockfish Harry,

Following my first test here: Korg DS-DAC-10R on ROCK, No native DSD playback strategy, I tried to connect my Korg DS-DAC-10R to RoPieee and I have the same result: no native DSD support. Is this normal ?

In advance, thank you Harry for your response and good evening.

Do send Harry a feedback packet on the advanced page and let him know the number code returned here. The dac needs to be on when you do it and wait at least 10 mins aftwards to let the feedback be sent to his end.

Thx. Done.

Logs have been sent to RoPieee HQ with unique identifier 5327ad101d741626

I would still ask the manufacturer about Linux support and dsd

Hi @Dirk-Pitt,

Thanks for the logs.
These show that the DAC does not support native DSD.

However, there might be a ‘but’. They way how the device announces itself it might very well be that there’s a mistake made in the description, so I’ll do the following: I’ll patch the kernel for RoPieee’s next update so you can try.

Trial and error, with a high change of failure. But hey, let’s give it a try :wink:

I’ll keep you posted.

Thanks

Thanks for everything Harry.

Hi,

I looked into this myself at the time and I understand my Korg DS-DAC-100 uses the same driver as your DS_DAC-10R unit so this should work the same.

I have this setup to playback Roon via HQPlayer for best quality. This achieves bullproof up-sampling and playback of DSD128 using all Roon sources and formats. I output to active monitors via the Korg balanced outputs without a preamp, using a passive balanced volume control between the Korg and the active monitors. This additional volume control was needed as the volume control on the Korg unit only controls the headphone jack.

And it does sound good as well :slight_smile: So it is possible, hope this helps, Neil

TC Electronic make a nice balanced knob control for not too much coin.

Is that using Windows, because I would expect there to be no issues with Windows.

Yes, using Windows (only use with 7 as haven’t upgraded that PC to 10 but that is likely to work too)

Unfortunately a working native implementation says nothing whatsoever about the possibilities on Linux.

We’re still a far cry from vendors actually caring about Linux :wink: