Label preference not applied[fixed]

Hello. I’m ending my trial, so far very happy with the results. I am having just two problems (the other one goes in another thread), this one is related with the Labels tag. In Preferences/Library/Import settings/Metadata preferences for albums/Labels I chose Roon’s data. If I manually edit the info of a given album, Prefer file data is chosen (and Roon has metadata of the Label because I can see it and choose it if I want). I understand that this goes against my preference, so I’m clueless as to why this is happening. I haven’t inspect all my albums, but this behavior is happening with many albums. Using the Focus option, I see that there are many labels, so there is a portion of my albums that is in fact using roon’s data and using the preference option I selected in the settings.

Any ideas or help is welcomed, thank you!!

Could I get an answer? @mike @Eric @Someone-from-roon

Thanxs

Hey @Ezequiel_Kinigsberg. Not sure I completely understand the question.

On both screens – in your library, and at the album level – the choice is about picking a preference. If you have data in both your file tags and in Roon’s metadata “layer”, we will use the data from whichever layer you’ve chosen.

If one of the layers is empty, whatever data is available is used. More information about how this all works is here.

So, in the screenshot above, it looks like you’ve edited this album to use label info from your file tags, but Roon hasn’t found any label info in your files. Does that answer your question?

If not, can you give me a bit more information about what actions you took here, and what you were trying to achieve:

Sorry If I wasn’t clear. Let’s start over. My desire regarding the Label info, is to always use Roon’s data (I bet almost none of my albums have the label metadata embedded because I never really completed it, there may be some that already had it but they are probably a minority).
Reading from the kb:

For some fields, you can set Library Preferences, so that everything in your collection always defaults to your preferred metadata. This is great for fields like Genres or Import Date, or for text fields where you’ve done a lot of grooming (like album or track titles). For more information visit Library Settings

My understanding is that if I choose Prefer roon in any of the option found in Preferences/Library/Import settings/Metadata preferences for albums , by default, I should see Roon’s own data in any album’s info, unless I obviously edit that album in particular (which I haven’t in the case of Label). I hope my images make sense now. Am I misunderstanding how this works?

Yup that’s what this library setting will do, but not always – you’ll see Roon metadata for labels only in cases in which Roon has retrieved that info from our metadata service.

For albums that we have no label data, or for albums in your library which Roon hasn’t identified, we’ll still fall back to label info from your tags if it exists.

So, am I correct that you are seeing albums in your library that look like this, which you haven’t edited recently?:

If so, I’m wondering if maybe you edited those albums before you set the library preference? The library preference will apply to two kinds of albums:

  • New imports
  • Albums you’ve never edited before

What it won’t do is clobber edits you’ve made previously – to do that, you’ll need to select all your albums, click Edit, and set the preference as an edit. Then, future albums will be set the correct way due to the preference.

Hopefully I’ve got it now – let me know if not :slight_smile:

2 Likes

Hello mike,

Yes, that’s my point. I have almost 1500 albums. There is no way I manually edit all of them, and I haven’t done any bulk edits either. I did edit some of them until I found this issue and then stopped. The example that you posted in your last reply, is what happens, but in that case it is not that bad, because since the album has no Label tag, in the credit’s Roon’s data is shown (although Roon’s data should be ticked…). But, here is another example more weird. For example, Zero 7 - When it falls (which I am sure I didn’t to any editing on). As described earlier I set Prefer roon, regarding Label’s album data. In the edit pane of the album I see:

But, in the credits, I see ELEKTRA:

So basically Roon is displaying ultimately what I want to see, but the selections on the edit’s pane are not complying with the global preference. Any idea on why this might be happening?
I hope I was clear.

Regards

Yup, it’s clear now – thanks for explaining.

I took a look and this actually looks like a bug – the setting is being applied but the Edit screen seems to be displaying the checkbox incorrectly.

We’re going to do some testing and open a bug report – should be fixed for a future release, but we’ll let you know if we have any issues pinning this down.

Thanks again for the report @Ezequiel_Kinigsberg!

This was fixed for our last release @Ezequiel_Kinigsberg – please let us know if you’re seeing otherwise.

Seems to be working as expected. Thank you!

This topic was automatically closed after 5 days. New replies are no longer allowed.