Latest Mytek Brooklyn Firmware (2.36) breaks high res playback


Roon Core - Dell R510 / 24GB RAM / Xeon Processor / Windows Server 2016
Roon Bridge - RBP3
Remote(s) MBP (OSX), iPad
DAC - Mytek Brooklyn (first model)

I’ve had a smooth playing system for quite some time. Tonight while fuddling around, I saw an option that allowed volume control of the DAC via Roon, which didn’t work. I did some online searching and found a post that indicated later firmware revisions to the Mytek enabled HID volume controls. I thought, SWEET! So, I plugged the Mytek into my Macbook, loaded up the Mytek Software, and updated to FW 2.36 (from 2.06) without issue.

I then connected the Mytek back to the RBP3 Bridge and tried to play my first audio track, which was a 88.2KHz / 24 Bit file. It stalled at 0:00 and then moved to the next track, same thing, then so on until it hit the end of the album. I tried playing a 16/44 audio file, Same issue. I hit the play button several more times out of frustration and then it started playing!

I thought - ok, cool, something was hung up. I tried the 88.2 file again, same problem. Went back to 16/44, hit play several times, then it started playing. I thought, well then it’s an issue with 88.2KHz and this new firmware (I have been able to play this audio track prior to FW 2.36). By the way, volume control now worked with this firmware, so I thought I’ll live with the fact it cannot play back this one audio file.

Later, I tried DSD. Same issue. Then tried 24/192, same thing. After several trials, it seems to be when trying to play back anything > 24/44 (so 24/88, 24/192, DSD).

I then connected the DAC directly to my MBP, and tried Audirvana. Plays all files without issue. Switches resolutions, etc.

I thought - wow, odd. So started messing with the menus in the Mytek and noticed all sorts of new items. I.E. A way to disable USB volume control, and other stuff.

I also noticed that as soon as I connect the Mytek to the RBP Bridge, it switches the Word Clock option on the Mytek from Internal (which is usually the default and what I want) to the AES digital input (which I do not use). It shows “No Lock” until I switch it back to Internal.

I then tried disabling USB volume, switching roon back to fixed volume, but no dice.

I then rolled firmware to 2.32 (the only other firmware available on site), same issue. Now I’m like, crap, there is no other firmware to download!

I then got the idea to copy the URL for the firmware download, and modify the URL to 2.07, and it worked! I downloaded 2.07. I then flashed to 2.07, and everything is back to how it was, working, but no volume control of course.

TL;DR - Mytek Brooklyn with 2.36FW breaks high res playback. Not sure if you guys have one of these there.

Did you, at any time reboot your bridge and/or core? Adding that functionality was a significant change that a reboot might have been needed to pick up. Otherwise I am stumped.

i’m running 2.3.6 on my original Brooklyn and no problems here. in my case it was connected to microRendu and now ultraRendu.

in fact, this firmware is much more stable than the version you were running before — especially when playing hi-res music in different formats.

it’s likely to be your settings on either device rather than the firmware. but i would first start with a full power cycle on both devices before experimenting.

btw, does this skipping happen with music stored locally? streamed from tidal?

i have had skips like this when streaming tidal in cases where my internet is especially congested. never had this occur with local files.

Just a a reminder - works great with old firmware, not with new. Reboot has no effect. Not skipping. No lock. Tagging @Mytek_Official .

One thing I didn’t try was eliminating the RBP. I guess I could try making my macbook an endpoint.

Ok - you can play > 24/44 files just fine? 88/24, 192/24, DSD64/DSD128? If yes, mind running through the Brooklyn settings?

What are you running on the RPI ?

If not Ropieee, it is probably worth a try as there were some specific releases for the Mytek.


sorry for the terrible photos – best i could do with the time i had

1 Like

Just running the roon bridge software directly from Roon, never had an issue. I’ve looked into Ropieee if I wanted to use a 7" screen for display, but other than that no need. I’d hate to make too many changes at this time.

I hear you (just want to listen to music!). I run it without any display, so was not a big deal for me to switch. It autoupdates (including the underlying raspberry pi software) once setup so has been fairly hidden maintenance wise. I always keep a spare microSD card around for testing…


I may give it a shot soon. Before I do that, I may connect my DAC directly to my MBP and see if it works as an end-point that way, if it does then I know it’s the bridge.

OK - I’ve updated the FW, and connected to my MBP. Configured it as exclusive mode / integer mode device and I’m able to play back everything just fine, and adjust volume. So the culprit is with the bridge. I’m going to do litmus testing, and if repeated failure with bridge, will try Ropieee (need to find a spare microSD card)

Holy Crap. Just moved to Ropieee, this works great! Case closed, I guess? @support FYI. Latest Mytek FW w/. your roon bridge software on RBP3 doesn’t work >24/44.

1 Like

Wow, Ropieee can do DSD 256?! How is that possible under Linux? Thought there was some sort of limitation via USB and Linux built-in sound drivers. Cool!

Roon Bridge is the same on Ropieee / DietPI / wherever you install it on.

Ropieee is a special bird since @spockfish is pretty active compiling DAC patches into Ropieee’s kernel.

Be happy. :slight_smile:

1 Like


Before moving to Ropieee, what software and version did you have running on RBP3 originally when it didn’t work?

The latest. Don’t really have a choice in the matter, Roon auto-updates all of the time.

What was the basic OS that Roon Bridge was running on. That is what may have been out of date. FYI some are running on quite old Kernels but Ropieee is ahead of the curve there, and with DAC patches and it looks like that is the difference.

Great question, I do not remember. I loaded it a few years ago. That may have been the culprit then. Unfortunately I ran out of 4GB SD cards so I wiped out mine for Ropieee.