Latest new albums added to my music library are MIA in watched folders

Dear Support Staff:

Recently I added six (6) new albums to my music library that roon watches. For the first time since becoming a lifetime member, those six albums DO NOT APPEAR in roon. I opened storage to view the watched folders I have selected. Clicked on forced rescan for both folders, but NO JOY! roon refuses to add those albums which are in the folders roon watches.

What to do, please?


Update, I just noticed while using the “new” remote app, that one of the six new albums has been added and thus available in roon. I do not know what triggered the addition of that album. Or how to manage roon’s operations to add the remaining five (5) albums. I expected all new additions to watch folders to appear after launching roon. Are my expectations incorrect?

Please, what to do to add those missing albums to roon. Thank you in advance.


Hey @REShaman,

Anything distinctive about these albums? New format? Source? Different folder structure?

Can you let us know some more details about the files and what they look like on disk? Feel free to post a screenshot of the folder.

You could also try this:

  • In Settings, turn Show Hidden Tracks And Albums to Yes (if the albums show up at this point, stop reading! :slight_smile: )
  • Sort the album browser by Date Added
  • Grab one of the missing files and drag and drop it into Roon
  • Make note of the popups – you’ll probably be asked do you want to copy the file (select Yes), but you may or may not be asked if you want to copy a duplicate

Let us know how this goes, and this will let us know if there’s something related to the files themselves, the way they’re organized on disk, or something related to Roon’s duplicate detection.

Also, be sure to let us know some of the information in the thread at the top of the support section – specifically, what your setup and storage devices are like. Thanks Richard!

Hello Mike,

Thank you for your response. To answer your first questions, the albums are downloads from HDtracks in AIFF format either 96 or 192/24. The other four albums are redbook CDs converted by XLD to AIFF 44.1/16. All of the albums are consistent with my library. In other words, there is nothing different about these albums that would distinguish them from “thousands” of the other albums.

I also tried the show hidden albums/tracks. No Joy!
Sort album browser by Date Added, No Joy!
Grabbed the Woodstock DL and added into roon. Was queried if I wanted to copy the file, I selected yes. Did not show up in recent albums.

Four of the albums that are redbook rips are by the same artist, Stacey Kent, as two other albums added to my music library which appear in roon. Not sure what you mean by a screenshot of the folder. All these albums were already added to my iTunes library, so if I open iTunes, all six appear. The 4 Stacey Kent albums reside in a Stacey Kent folder with the rest of the albums, 6 or 7 with different titles starting with her name. My albums all reside in a music library folder with individual artists and within the artist each album separate. All of these library albums have been added without issue. They are all stored on a Promise Pegasus Thunderbolt Raid 5 R6 12TB which operates flawlessly with roon.

Have I missed any information that would help you help me?

WAIT! I just glanced over at my 27" Thunderbolt Cinema Display, and (YIKES!) they’re now ALL present in the roon display of recent albums. Sorry to take up your time. I do not understand the delay. Is that expected when first launching roon for several new albums recently added to music library to take time for roon to add those new albums from the watched folders? My expectation which is apparently incorrect based on performance presently is that added albums to music library would be “instantly” added to the recent albums section of roon as it has occurred since updating to V1.1. Perhaps the additions from watched folders require more time than instant.

They’re there now. Perhaps your steps to take triggered the addition. This is the first time so I do not know what worked. But, thank you for the excellent support as usual! AND, love the remote app. It is marvelous, truly! Never experienced such a gorgeous presentation from an app. Well done roon!!!


Ok, I’ll drop you a PM and we’ll get a file or two from you to see what’s going on here.

We fixed some issues with our AIFF decoder for 1.1 but we’ve heard one or two reports that maybe we caught most but maybe not every case. Getting some media from you will help, so I’ll be in touch.

Thanks for the report!

I’m having a similar problem, triggered by adding two new albums to a watched folder that do not show up in Roon. I have gone through the various steps above (manually copying into Roon, sorting by date added, restarting app, waiting overnight etc.) but Roon is stuck on “Adding Music to Library,” saying “Of 417 Tracks, 13 added, 13 identified” (and the icon is endlessly recycling),) so there may be other tracks that are also not showing up. Any ideas?

Hello @kschacter, lets look at your logs. I’ll PM you shortly.

I can now no longer add tracks to my Library from Tidal. It seems Roon is stuck on “Adding Music to Library” and the queue of tracks to add just gets larger.

Mike - I’m having a similar problem. I added a new album two weeks ago to my watched folder and just got around to wanting to play it today. But it’s nowhere within Roon to be found. I did the sorting of albums by Date Added, tried using the search to look for it. Nowhere to be found.

I went and checked the meta data for the tracks within (used Metadatics) and everything seems in order.

What I didn’t do was drag the album folder to Roon. I started but Roon gave me a message that said it was going to copy the album into its library, giving me the impression it was going to make a copy from the Watched Folder and put it local. I don’t want that - i.e. all new albums can only be copied to the local drive and not watched on the shared folder.

My setup is a NAS server housing all tracks, sorted by artist & album. Headless MacMini running Roon Server and a number of apple devices running roon clients.

I could try to a Force Rescan but would hope that isn’t necessary, especially since I had to do a bit of massaging and merging albums after the last rescan.


I was able to fix it, rather easily, but I’m pretty certain the fix isn’t what you have in mind. I logged onto my MacMini, stopped Roon Server, restarted Roon, and it found the missing album within a couple of secs.

Please recall that I reported on a different thread an issue where Roon Server can’t re-find my NAS after it shuts down in the evening and restarts the next afternoon. You said a fix hopefully was coming in the next Roon release. So until then I now keep the NAS running 24x7. See Content isn’t added when NAS wakes up

So it appears right now I’m broken if I keep everything running (when adding new albums) and broken if I shut things down (putting server to sleep) - Damned if you do, damned if you don’t. At least I understand the problem and have a work around. :smirk: