Latest Nucleus+ cannot find zones

I am on my third Nucleus+. The first one was DOA; there was a part rattling around inside its enclosure. The second one died after about one week; probably one of the major components failed; that happens with electronics. After returning the second one to my dealer, he loaned me his demo unit. It worked perfectly, including discovering every device on my network which contains music files. Today, I received from my dealer a third unit. When I unboxed it, I noticed that the plate on which the inputs and outputs are mounted was slightly askew, tilting down to the left such that the bottom half of the wording “19V” is obscured. Nonetheless, I proceeded with the installation and all the cabling did fit. The Nucleus+ was discovered on the network in short order, and it connected easily with Tidal; the HDMI output streamed nicely to my external DAC.

However, there is one big problem. The Nucleus+ cannot discover any zones other than (1) the iPad which controls it and (2) the Nucleus+ itself. It cannot, for example, find the Lumin T2 music streamer or the Bluesound Vault, both of which are sitting in the same rack (on different shelves) and are also connected to the same networking switch, or the Sonos, which is connected to my primary router/switch located in another room. The demo unit had immediately discovered these plus other devices such as my wife’s computer and our latest 4K TV, as did the prior Nucleus+ which had died after a week.

I tried such obvious fixes as rebooting the Nucleus+, checking its cable connections, etc. to no avail.

Virtually all of my sources are hardwired (using Cat 5 or 6 shielded cable) to our network rather than via WiFi. Our router and secondary switch are latest generation Luxul units.

What might you suggest as a fix? Earlier today the demo unit functioned perfectly, displaying several zones. This new Nucleus+ cannot find any of them.

Thank you!

Hi @Jonathan_Meyers,

Can you confirm that the Nucleus is fully up to date?

Verify the network LED at both the Nucleus+ and the switch flashes normally.

Please power down everything on the network, including the Nucleus+, iPad, switches and all audio devices. Power cycle the WiFi router. Wait for 5 minutes, then power up the switches, iPad and Lumin T2. Leave other network devices powered off temporarily if they’re not essential.

With the Lumin T2, you’ll need to enable its Roon Ready function (default).

With the Roon Core, go into Audio Setup and find Lumin T2 under networked Roon Ready devices.


Many thanks. The one thing I had overlooked was rebooting the Luxul switches. Once that was done, the Lumin T2, as well as several other devices, was discovered – and I enabled them all. The two sources still missing are my wife’s PC and my BlueSound Vault, but I’ll figure out how to get them online somehow, I am sure.

All devices have now been discovered. The Bluesound Vault needed a software refresh, and my wife’s computer had to have her IP address entered manually as a storage device.

Having to reboot a switch to cure a network problem worries me. Is your Luxul switch a managed switch? In your May 11 support request you mentioned you have a Cisco managed switch but I didn’t see a Luxul switch.


You are correct. My home automation contractor won’t be replacing the Cisco switch with a Luxul one he urged me to purchase until the first of next week; I thought he had already done that work

Regardless, by simply unplugging the power cord from that Cisco switch, waiting ten minutes, and then reinserting it, everything worked fine immediately and still does after several hours of usage. Perhaps performance interruptions such as that is why he wants the Luxul replacement.

I appreciate your interest and follow-up. It demonstrates a unique level of customer service by Lumin.

If you’re replacing network switch(es), note that for use with Roon an unmanaged switch is preferred, not managed switch.