Latest Roon IOS Remote crashes immediately after opening on both iPhone and iPad

Since installing latest Roon Remote app for IOS, app crashed immediately after opening.

Using IOS 16.3.1.

I removed (deleted the whole app) the Roon Remote app from iPad, and then downloaded the app again. The app ran until I entered something in the search field, and then crashed.

Everything works fine running Roon off MacOS. Just the IOS apps not working since installing the latest version that just came out.

Please advise.

1 Like

I have exact same issue on Iphone and Ipad. Works fine on my Android phone which is what I am using to type this

Not to proove you guys wrong, but for me Roon Remote on my iPad Pro 11", running iPadOS 16.3.1, everything is working fine.
This is going to be a tricky one.

The one thing you could try (again), is to remove Roon Remote completely, power off your ipad, power it up again, and download and reinstall Roon Remote.
Please make sure you have the latest release of the app : Roon version 2.0 build 1211.

Thanks, Dick. Not to prove you wrong, but I did all that again, and verified all that again. And as soon as I select an album it crashes.

Please advise.

I have exactly the problem with both my iPhone and iPad. Have deleted apps on both. Powered down and restarted. Re-installed the apps. Still broken.

My server is ROCK on an Intel NUC. Have rebooted that and still have the problem. Cannot confirm which build of Roon Remote I have as it crashes immediately on opening, but problem only happened after update from the App Store yesterday/today.

Problem solved. Just got prompted for a sever software update to Build 1211 and it now works. So it appears the newest iOS app is not compatible with the previous ROCK server build.

I have an iPad 12.9 pro , running everything latest , it behaves normally - very odd. I have an old Mini on 14.xx which hangs occasionally and won’t allow me to stop play but my 12,9 has no issues

Doesn’t help but confuses ?? ODD

Does it hang or just “go away”, maybe detail just what you were doing . Search is now going back to the cloud as of 2.0 so that may be the cause.

What is the network stuff like it may be specific to your set up ?

Do you mean updating the NUC Rock software?

Yes. I deleted and reinstalled the app again which allowed me to open it, and was then shown the updates available prompt for a core update. That runs, and does a database update. I had to manually reboot my NUC after the core update as it did not restart automatically. All working normally now.

Since crashing was on both iPhone and iPad, I thought the problem might be the core. Once again ( a chronic problem on my M1 iMac) new core software wouldn’t install. Got an error message, so I deleted all core Roon, and deleted the “bits” folder in the hidden Library folder (or whatever it is called) and reinstalled new core software from Room web site. I’ve had this install failure problem for over a year now. When is this going to get fixed?

Since installing new Roon core for Mac all works fine now. Why can’t Roon provide Release Notes that says “When installing new iPhone or iPad clients, the core software versions must be the same load number as the client. Click here for directions to load new core software if you automatic installer does not work.” How about an error message on both clients AND the core that says “ERROR: Core is on an older version that is incompatible with your new client software. Click here to install new core. Click here to verify core version. Click here if installation does not work.”

I have never used software that requires so much manual effort to keep it running as Roon. Why can’t this core installer issue get fixed? It is getting really old deleting files in hidden folders to install new core software versions.


Sorry to be so technologically challenged but how do I go about accessing the ROCK software on my laptop? Does it automatically connect or do I have to go to a website?

Install Roon Remote on your laptop. Navigate to Settings - About and it will show the status of your core software. There should be a link to click to update to the latest build (1211).

Thank you, David. I looks like it is finally sorted out. Not exactly sure what I did and for a while I lost total connection and it was saying that I was running different versions of Room on my Core and my remote. After trying different things, I believe I reinstalled the software and all seems to be functioning as it should. Thank you for your guidance!

Glad you got it working again. Not Roon’s finest hour that they enabled incompatible versions of server and remote software out in the wrong order.

I have the same issue.
I just installed Rock onto a compatible NUC using the link on Roon guides to download the image its is still version 2.0 build 1143?
Now when launching Roon app on ipad, iPhone AND windows all apps crash. So I don’t know how to update to 1211
Where is the image for 1211, as I cannot open any app I have.

Use the Reinstall Roon OS button on the ROCK/NUC’s Web Administration Interface to update your Roon Server to the latest version. That should resolve the incompatibility with your Roon clients.

Thanks just tried that but

Reboot your NUC and try again.

Having a go, now I have build 1234
Let’s see