Left and right speakers inverted in [EDIT] 384 upsampling

VI don’t know if this is unique to my set-up or if it’s a general issue.

Can HQPlayer users test the following.

Strawberry Fields Forever, Ringo is on the left.
On closed form, FIR etc, this is the case. If I change to poly-sinc short mp, Ringo is now on the right, change back to closed form, he’s back drumming on the left.

It’s not a Roon issue as it’s the same via HQP direct.

I rebooted the Pi3 (USB out to Hugo TT DAC) and restarted HQPlayer and the issue persists.

As I type I suppose I better try a full shut down of both and switch on/off DAC.

Okay, done that same issue, can some of you try this out please?
I’m using version 3.14.4.


On my system Ringo is on the left on closed form, FIR as well as poly-sync-short mp

Thanks for checking.

@jussi_laako what might be happening here?


I’ve a similar issue, but for some reason I associate it with DSD files or converting.
But maybe it is because I use FIR filters in PCM and Polisinc in DSD.

My DAC is a PS Audio Nuwave DSD

Just to add, in my system i happens with every music.

I’m away, and will only be able to check the filters vs file format next week.

Which OS are you using? Is this also without NAA? I haven’t been able to reproduce it…

Here’s a test file, it has 440 Hz sine wave first 15 seconds in left channel and next 15 seconds in right channel. Turn the volume down, it is pretty loud.


Windows 10 on a NUC, dietpi on the Raspberry Pi.

I’ll try this evening when I home to see how the test signal works and I’ll try the NUC direct to DAC also.


Here’s the same file converted to DSD64:

Okay @jussi_laako here’s what I did and what I found.

Using NAA (dietpi) the following filters went R->L
ploy-sinc -hb
polysinc short mp
polysinc short
polysinc mp

ALL other filters went L->R (correctly)

When I connected the NUC directly to the Chord Hugo TT DAC ALL filters worked correctly (L-> R).

I then tried an NAA image rather than the dietpi version. (I used both 340 and 342)

This is where things get annoyingly confused. About 85% of the time the above held through but the odd time one of the above would work correctly and closed from would go R->L incorrectly, restarting the program always corrected the closed form anomaly.

DSD worked correctly ALL the time.

the following probably isn’t very clear but shows what’s happening, I have the left speaker balanced to 100% so when there is sound it is the left speaker you are hearing, when there is no sound it is the right speaker you are hearing (so to speak!) You’ll need to turn up the volume.

the first file is the flac, the second the dsf and the third the flac again.

Just now I quickly tried rather than using auto to reduce the upsampling on polysinc short mp to 192 and this worked correctly whereas going back to auto had the R-.L inversion.



Something fishy going on in RasPi. Could you try running networkaudiod on the same computer where you have HQPlayer and see whether the problem is still reproducible?

I tested both PCM and DSD with NAA today (not RasPi though), but didn’t encounter any problems.

I don’t fully understand what you are asking me to do here.

Can you give me a step by step description (and baby steps at that!)


If you connect the DAC to the same computer where HQPlayer is, but instead of making HQPlayer play directly to the DAC, run the NAA software component (networkaudiod) also on the same computer and ask HQPlayer to use it for output instead. In normal cases this doesn’t make any sense, but for troubleshooting it may help because it rules out number of extra variables.

So I’ve gone to the website and downloaded networkaudiod-342
when I extracted this I selected networkaudiod from x64 folder and got the following error messages

Where do I go from here?


Just below the download button:

On Windows, Microsoft runtime is required, in case you get error message about missing DLL, you can download the necessary runtime here.


I’ve no excuse!


okay I’ve downloaded the runtime, clicked the networkaudiod from x64 folder, got a firewall message and I clocked allow and then this window opened

I can only see 2 NAA listed in the network adapter naming (I have 2 pi with NAA) but no other on the local machine.

Am I just being incredibly silly again?


Can you help me here @jussi_laako ?


That looks correct. But likely firewall is still blocking the discovery traffic… You should get messages on that window visible, when you start HQPlayer and go to either network naming or settings dialog in HQPlayer. If nothing appears, then packets get lost on the way.

There is now also HQPlayer 3.15 out, you could just in case check if it changes anything. Nothing specifically done about this, but this is strange enough problem that worth checking.

Well I’ve eventually got around to putting the NUC back connected to the Hugo and used the networkaudio output rather than the asio as suggested.

All the filters played correctly right to left. This suggests that it is the Pi3 that is the culprit.

Is there anything I can do to try and give your some information so that I can use the Pi as for best sound it I’d like to be able to use the NAA.



What OS image are you running on the Pi? Is it the full SD image I provide, or DietPi or something else?

The data transfers somewhere fall out of sync on the Pi and unfortunately this misbehavior is not going to be easy to figure out… It could be on the OS level, on the hardware level, somewhere in the co-operation of the two, or something else…