LG Chromecast sound bar not showing up in Roon


In settings/audio, the box which says enable for my sound bar will not change to let me set the settings.

When I try to click on it, it flashes and my sound bar changes to WiFi for it, but the switch will not change to let
me set it up so I can hear the sound bar.

Can you advise me on a solution please.


In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hey @stephen_ollerton,

I wanted to check if you still needed help enabling your sound bar in Roon? If so, could you please share the information @Carl so kindly asked for? (thx @Carl :pray:)

1 Like


Just arranging for my friend who is disabled so I can go to his house and bring him to my house, he used to install computer systems in schools etc. until he became disabled.

He has a better understanding of computers and might be able to reply to about my set up.

Can’t enable sound bar in Roon settings-audio. it does not show sound bar anymore. used too. also since plugging in apple super drive the nucleus has been playing up, won’t reboot, it said unable.It lost connection with internet, it was hard to connect again but managed later.Still the same. My setup isSOUNDBAR — LG-SH8 -



Please can you help.
Thanks Ste.

Hi @stephen_ollerton ,

Are you trying to use google cast to your soundbar? Do you see the soundbar appear in the Google Home app? Are you able to cast to it from other apps such as Youtube? Do you see other Cast devices appear as expected in Roon?

Hi Noris Don`t know about google cast it used to be sum-at play at first when I got Nucleus now it doesn’t show my soundbar all the time in audio settings if it does it will not enable but the soundbar switches to wi fi , got it working with HDMI cable in soundbar after a lot of unplugging and plugging back in.it was not showing HDMI in audio settings until I unplugged every thing then plugged back in. When left switched on over night when it was ok and all my albums was in it was fine the day after with HDMI cable but when switched off over night I had to start unplugging again and turning off/on soundbar to get HDMI in audio settings and all my albums came back in. It got a bit better when I got rid of some lan cables from switch box including tv lan cable.

Hi @stephen_ollerton ,

I ran diagnostics on your Nucleus unit and it looks like you are having issues with all your zones appearing, I would advise performing a Roon Backup first and then trying an Operating System reinstall and Database & Settings reset via the Web UI:

Give that a try and let me know if that helps with the issue. Also, don’t forget to select another Core on the “Choose your Core screen” following the reset.

Hi Norris
Tried reinstalling roon os after about ten minutes message said something happened check your internet that seems okay tried again no luck and now roon labs software says not running .

Hi @stephen_ollerton ,

Can you please try to reboot your Nucleus (power off, ensure power is completely off, power back on) and try the OS reinstall once more?

Hi Norris reinstalled roon os and database and settings message came up saying ip had changed put the right one in static ip and not all
my albums are there now after reinstalling database don’t know if it was right backup or if I backed it up correctly.

Hi Norris when I tried turning nucleus off then on I had lost my dac and hdmi s on audio settings screen also there’s 200 albums missing
off my home page.

Hi Norris when I reinstalled roon os and settings
there was no choose your core screen that came up either

Hi @stephen_ollerton ,

The Choose your Core screen should only show up when doing a Database Settings Reset, an Opertaing System reinstall does not trigger a database reset.

I’m not sure I understand this part, was the database reset successfully? If there are any errors, can you please attach a screenshot of what you’re seeing?

After performing a database reset, it is expected behavior that audio settings are reverted to “factory default”, meaning no zones would be enabled. The way to re-enable them is to manually do so under Roon Settings → Audio or restore from a Roon backup from before the reset.

Tried doing a reset on database and settings waited over half an hour then stopped it message came up telling me error 2 try again if no luck get in touch with you.

Hi @stephen_ollerton ,

Thanks for trying that, it is very strange that the reset is not working. Are you still able to manually access the Nucleus Database Location (Data/RoonServer) via Samba? Can you please check to see if there are any log files generated under RoonServer/Logs and upload them here and let me know?


After sending the logs you can also try a manual RoonServer reinstall:

  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Let me know if that helps!

Hi Noris uploaded the logs to the following address as requested https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external
thanks Stephen

Hi @stephen_ollerton ,

Thanks for sending those logs over. We looked over logs and we are seeing a lot of Network related errors contained in them, including NameResolutionFailures. What kind of router are you using, does it have the latest firmware updates?

We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS, this would help with the NameResolutionFailures but it won’t help with the router dropping local area connections.

Hi Noris my friend has changed the routers dns server to google dns with a brand new router from
shell energy my ISP it is a technicolor serial number CP2126SABA9 will we still have to do firmware update . I still cannot get to settings page on nucleus.

Hi @stephen_ollerton ,

Where have you purchased your Nucleus from, a local area Roon dealer? It sounds like RoonServer isn’t able to start and you may want to involve your dealer for more advanced troubleshooting.

Getting RoonServer to start via the Web Interface would be the first step here, as if it’s not running, then Roon isn’t active on the Nucleus. Unfortunately, it doesn’t look like your nucleus is communicating with our servers at all, so getting additional logging information is not possible at this time.

You can try to perform a manual database if you can still access the Nucleus via Samba by using these instructions:

  • Stop RoonServer from running in Nucleus’s WebUI (if running)
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database