LHLabs Geek Pulse no longer works

Anybody else having this problem?

The Geek Pulse has worked fine with a USB connection direct to the Roon core Windows 10 NUC, and to Windows endpoints. But it gradually started misbehaving: it was very sensitive to boot sequence (the Geek LPS power supply, the Pulse itself, the Core or MicroRendu). If things were not booted right, Roon would present an error message saying it can’t initialize the device.

Actually, come to think about it, it wasn’t probably Roon: the error message was displayed in an ugly way, yellow text in a gray box overlaying Roon, maybe this is the driver (but a driver should not do any UI) or the OS.

Anyway, I know this is not a misconfiguration or hardware error or network error, because the device sometimes does play an album, and then fails on the next album.

Any suggestions?

I’m otherwise giving up on this (not inexpensive) device and going looking for another DAC.

I remember that @mike used this DAC for a demo once and ran into something similar sounding-as I recall, there are ways to get the device into a very confused state, and the problem was Windows specific. The device would remain wedged until it was power cycled–to the point where after wedging the device, we could move it to a Mac or Linux machine and it would stay broken–extremely unusual behavior for a USB device.

I think that using ASIO and possibly Native DSD playback were involved in triggering the problem. Possibly changing sample rates too.

I think it was much more stable in WASAPI mode, but only after power cycling the device to clear the bad state.

If you are using ASIO, it’s worth mentioning: ASIO drivers aren’t actually drivers–they’re in-process COM Servers that talk to drivers. ASIO “drivers” are able to present UI and often do so (whether it is a good idea or not).

I don’t use native DSD, but the times when it played ok and then failed may have involved a sample rate change. I’ll test that, if I ever get it working again.

Uninstalled, reinstalled and chose WASAPI. Still didn’t work. The error message looks like this, do you know where that comes from? (I hate when error messages are not attributed…)

That said, the device doesn’t even work when I click Test in the control panel.

Annoying. I’ll need to get a new DAC for my headphones. The Meridian 818 has a headphone mode which I can use to drive a Bryston headphone amp, but the user interface is annoying: I can’t select headphones in Roon, I have to power off the 818, and click up arrow on the Meridian remote (or its virtual iPad equivalent) and look on the 818 control panel to verify that I toggled this on and not off, and then select the 818 in Roon. This is how we did things in the 70s… So now I have to go shopping again.

The error message is from Roon – it pretty much means what it says.

I wish you happy shopping, sir. You deserve something nice after this. :slight_smile:

Thank you. Yes, after a frustrating experience some retail therapy is soothing…

That error message is ours, sorry :frowning:

It means that we tried to open the device driver, but one of the system calls failed.

I finally got a firmware update – LHLabs is having difficulties and isn’t very supportive. But this fix worked, both connected to the Windows 10 NUC Core and to a MicroRendu.

So no shopping right now.

I forgive you :slight_smile:.


Just stumbled across your post about the Geek Pulse! Do you have any more information about that firmware update, as I’m having exactly the same problem. Thanks!

(Was offline for a while…)

Send me an email address and I’ll forward the info I got from LHLabs Support.

Hi! Thanks for getting back. Just use *****

Will remove it from here as soon as I got your message.

Sent the mail i got from LHLabs support. Note the attachment.

Hi @AndersVinberg,

I’m also curious about the new firmware. I’m not having the problem you described, but almost every time sampling rate changes I get noise for between 1 and 10 seconds and sometimes the noise doesn’t go away at all until I do something like stop and restart playback, change input etc.
Do you have the vanilla Pulse? Mine is the vanilla, version 1V5 revision v1.50.


I have had that problem. Went away with the new firmware.

1 Like


@AndersVinberg, can you forward me the email?. My address is: jmb at tinet.org


I’m traveling in Europe.
I’ll check when I get back, but I’m not sure I can find that email…

Can you please send me the LHLabs Geek Pulse irmware update and info?

Thank you!


I’m sorry, that was years ago, and I no longer have the Pulse.
Don’t have the link or update either.

Can you please send me the LHLabs Geek Pulse firmware update and info?

Thank you!


If you are having the transport error issue with your Geek Pulse as described above — and I have had that but not any issues on switching bit rates or the like — here’s how I fixed it. I found that all it takes is to power down and re-power up the DAC itself. Now, in my case, I have the DAC powered by the companion LHLabs linear power supply. Powering the power supply down — which obviously shuts off the DAC — does not solve the transport issue for me. Only using the power switch on the DAC itself has worked. Don’t ask me why.

My Geek Pulse is connected to Roon via USB to a RPi3 running Roon Bridge. JCR