Library is severely missing music. (all of it practically)

Roon Core Machine

Windows 11

My music is stored on a server in my house and accessed via samba. I’ve jumped around between a few music players (musicbee, foobar) and both of them import my full library.

I have used Roon a handful of times here and there and never had any issues importing my music library. I have done so with this exact samba share previously. For some reason it never imports past 600 or so tracks. There are 80,000+ so it missed a few. I’ve tried a few things. Reinstalling, installing Roon core on my server and then connecting the windows Roon app to it. Regardless the result is the same.

No there are no skipped files, no my files aren’t corrupted.


What format are the missing files in? You mentioned they weren’t skipped so I’m curious why they weren’t read in.

They’re a mix of mp3, flac and wav. I’m totally lost why they aren’t read either. My thought was maybe a bug but I didn’t see anyone lately with this exact issue.

Yeah, that’s weird. Have you tried mapping the share as a local drive?
E.G. R: = \\nadeshiko\server\Musical

yeah i have. i usually access it that way in explorer

i just added it as a network share in roon when i was just trying different things.

I’ll bow out to smarter people then.
Good luck. That’s odd.

1 Like