Library scan stops play

A new issue since the latest software update is that library scans seem to stop play. I get a message saying that the core (Nucleus) can’t be found. Then it reverts to the normal screen with a whirling circle at the top. Clicking on the circle takes me to the library scan screen. After the scan finishes, I can resume play as normal.

I don’t have a very large library (about 10k tracks), and am not using DSP or so I don’t think the system can be overstretched. Other network info: Draytek Vigor 2860vn router; CAT6 cabling; Cisco SG 110 Gigabit switch, Netgear gigabit mini switch (next to the Nucleus); Synology RS214 NAS (on which the music files are stored).

It may help to check on and change your library analysis speeds…

OK. Thank you. I’ll try those settings.

You can’t be using all the cores to do the analysis try using only 1/2 the count.

I’m afraid I don’t really know what this means.

It may be worth saying that I hadn’t changed any settings before the problem suddenly occurred.

I don’t know why, either…but it may be interesting to know your processing speed indication when you are looking at your signal path?

Anyway, after clicking the drop-down of ‘Background audio analysis speed’ select half the available number of cores to preserve some horsepower for music playback during analysis - which is my setting without such problem, but the screenshot is only an example of where you do that, not the recommended setting; sorry for confusing you. And yes, set ‘On-demand audio analysis speed’ to throttled for the same reason as above.

Keep dropping number of cores if that doesn’t fix it for you.
If your problem can’t be fixed this way I wouldn’t know any other thing to try.

1 Like

Hey @Jack_Bolton,

I’m sorry we’re only seeing and replying to the thread you’ve created today…:pleading_face:

Since it’s been a while and thanks to @Marin_Weigel and @wizardofoz’s interventions (thank you both!), I was wondering if things are still the same with your library analysis? We’d love to help :nerd_face:

Hi Rebeka

Thank you for following up.

Based on the earlier comments, I turned off “Background audio analysis” and throttled “On demand audio analysis” (since I didn’t think I needed either of these). I’ve had no repeat of the problem, but, of course, I don’t know if this is just a coincidence.

Last night the problem returned. The music suddenly stopped and there was an automatic library rescan. Of course, I don’t know whether the rescan caused the music to stop or whether some other event triggered both the interruption of playback and the rescan.

This morning I tried a couple of forced rescans while music was playing (to see if I could replicate the problem), and there was no interruption to playback.

1 Like

Hey @Jack_Bolton,

I appreciate you keeping in touch. Thank you for trying out the suggestions mentioned on this thread. Audio analysis happens automatically and on demand (when an un-analyzed track is played). We discuss it here:

https://help.roonlabs.com/portal/en/kb/articles/audio-analysis#Audio_Analysis_Settings

Could you please keep us posted if the issue resurfaces?

In case the issue is related to my music library being on a NAS, I have, for now, copied the library to a SSD, and connected this via USB to the Nucleus (which is connected via USB to my DAC). I have disabled the library on the NAS.

Last night, with this arrangement, there were no interruptions to playback, but it may be too early to tell whether this is the answer.

2 Likes