Library scanning never finishes

Details on your Core machine (OS, Hardware specs, Roon build)

  • Pinkfaun 2.16X Server, running on Audiolinux, AMD 7 3700 processor, 16GB RAM, 1 HD Samsung SSD 250GB for Roon + 2nd HD Samsung 4TB SSD for local music
  • Roon version 2.0 build: 1193
  • HQPlayer: HQPlayer Embedded 4.31.0

Details on your Remote(s) (OS, Hardware specs, Roon build)

  • iPad Air Pro – 128GB - running iPadOS 16.2 - Roon version 2.0 build: 1192
  • Samsung S10e – running Android version 12 kernel 4.14.113-25257816 – Roon version 2.0 build: 1192 Wifi 6
  • PC running Windows 11 Home - 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz 2.80 GHz Ram 16GB, Roon version 2.0 build: 1193

Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)

  • Ethernet & Wifi Mesh network (Wifi 6) built on 3 * Asus Zenwifi XT8
  • Connected to Service Provider modem
  • Speedtest connection speed ethernet 93Mbps download – 18Mbps upload
  • Roon Core connected via ethernet, Remote PC connected via ethernet
  • Mobile Remotes connected via Wifi6

Audio devices in use

  • T+A 8 DSD connected to Roon Core, using HQPlayerEmbedded, connected via USB
  • Endpoints : 1 * Cambridge Audio CXN v2 , connected via ethernet

Library details

  • Local library on separate internal 14TB + 12 TB SSD harddisks in Roon Server
  • Qobuz Hi-fi Sublime streaming service
  • 68429 tracks (4520 albums – 2388 local, 2132 Qobuz)

Backup details

  • Location 1 : USB disk connected to Core Machine - 2GB capacity
  • Location 2 : Synology NAS 10,8 TB capacity
  • Location 3 : USB disk connected to Synology NAS - 7,2 TB capacity

Description of Issue

I am reworking/improving metadata in My Local Library. As a result Roon starts rescanning the implicated albums.
However, Roon never is able to complete the scanning
As an example the last metadata update result in:

In this case, it seems to be stuck at 5 tracks before the end, in other cases I have seen 12 tracks or even more.
I can wait as long as I want, 1 hour, 4 hours, 10 hours, Roon never finishes.

However, stopping and restarting Roon server shows this:

Scanning has stopped. Of course it did as I stopped Roonserver.

Now my question is: are those 5 tracks scanned succesfully or not?
As I do not have access to the Roon logfiles on my audiolinux server, I have no way of knowing.

Your support would be appreciated.
Dirk

Apart from @joel moving it to a different category, it looks like this topic is not getting any attention.
As some others do, or have done.

Is my english that bad?
Am I persona non grata?
Does anybody really care?

Your guess is as good as mine.
Dirk

Hey @Dirk_De_Taey,

My extreme apologies for the long delay in following up on your issue here. I wanted to check in and see if you were still getting hung up on a handful of tracks you were editing?

If so, please recreate the issue and share the specific date and time the issue occurred at. From there we’ll be able to review diagnostics on your account to see what might be going on behind the scenes.

Thanks, and again I’m so sorry for the delay in getting to you. :pray:

As more than 1 month had passed, I would have thought this topic was automatically closed.

3 Roon releases later, I am happy to say that the issue has disappeared. No more scanning of leftover tracks.

I still have no clue however if these tracks have been added or dropped, as I do not know which tracks it were. But I assume they are added to my library.

So topic may be closed.
Dirk

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.