Library Transfer - Playlist Lists Tracks As Unavailable (2)

Hi Roon, I moved my ripped music from one drive to another and now almost all of it is showing up as unavailable (I’ve attached a screenshot). A few tracks are okay, most are not. I’ve read all of the other helps on this topic, it seems like I’m not the only one that has been affected by this problem…

  • After reading some of the other answers, I have looked and confirmed that the problem seems to be that all but 600-odd tracks are not being imported (I’ve attached a screenshot).

  • I removed the old storage drive and have loaded up the new one and Roon seems to be finding it fine and all of the folders/tracks are in place. (I’ve attached a screenshot.) But it just won’t import (almost) any of them.

Please let me know what can be done to fix this. Thank you. Solomon Major

Solomon, just a user here, but have you selected “Force rescan” of your E: drive?

Hey Robert, thanks for the note. Unfortunately, I have (multiple times). The answer is always the same: 618 tracks imported. … very frustrating!

I’ve seen other issues with loading (or reloading in this case) where a file may be corrupted and stops the process. Do you have any idea where it stops the scan, and can you remove those files (or file) and see if the scan continues?

I have no idea at all where it’s stopping. Is there a way to figure this out?

It does seem like alphabetically earlier files are there (say, “AFI”), but it stops pretty quickly (before “Bad Religion”), but I don’t know where it’s stopping in between…

I just moved a fully functional library from one drive to another so I don’t see how a file could have been corrupted. But computers are funny things, so I guess I can see how this could be a possibility.

For the files that have reloaded and visible in Roon, are tracks coming in alphabetically, or albums coming alphabetically? Without looking at your logs (which @support will probably request), I wonder if there is a pattern on what is loading, and then look at the next file and see if that is a problem.

I’m not sure how I’d be able to tell that… although I have only 618 tracks from my ripped music (out of something like 25k total tracks), I have easily 30-40k tracks from Qobuz. So I can’t just look at what’s in the library and say what’s been ripped–I’d have to sort through all the Qobuz tracks as well.

I’m guessing if it is a corrupt file/track, then it’s probably in your ripped music, not the Qobuz. Again, this is just a guess. Tagging @support for assistance.

The easiest (manual) way to identify a corrupt file is as follows:

Remove half the files from your watched folder. If this fixes the problem the corrupt file is in the ones you removed. If it doesn’t help, the corrupt file is still in the watched folder.

In the case of the latter, remove half of the files that are still in your watched folder. By adding and removing 50% of the files each time you can quickly narrow down the problem, even for a large number of files.


Brilliant Dave, takes me back to my programming classes in the '80s.


Thanks Dave. I’ll give that a try… it would be great if Roon’s import function was a little more robust than all that!

1 Like

Dear Roon (and Dave and Robert),

So I tried Dave’s suggestion but maybe there are multiple corrupted files because cutting the library at different points just resulted in different, seemingly random numbers of files being imported–none of them matching the number of files in the folder. So I tried deleting everything and just re-importing the whole library, while Roon was “watching” the folder for changes. This seemed to work okay and several thousand files were found and the process was still ongoing. However, it seemed like it was stuck on around 7k files so I hit “Force Rescan” and then watched the number of files drop from about 7k to 873. This is not great.

No, it doesn’t sound good. Two more suggestions, but I have doubts that either of them will help …

  1. Is anything showing in Skipped files (Settings → Library → Skipped files)?
  2. Have you checked that the drive you’ve copied the files onto is free from errors?
1 Like

I have been reduced to adding files one folder at a time and watching them get added to Roon in real time. This was working (slowly) and I was up to about 3k tracks, out of about 25k, as memory serves. (I even found one of the folders/files that seemed to be corrupted and did not move it over so as to prevent further library problems.) Point being, as kludgey as this solution was, it seemed to be working okay.

Unfortunately, I had to restart my computer (for other processes) and it seems as though Roon rescanned my storage upon restart. I am back down to 428 tracks in my library. This is seriously frustrating, it would really be great to get some help from the Roon team on this.

Tagging @support for you Solomon.

Thanks! (I probably should have known to do this myself, but this is the first itme I’ve asked Roon for support.)

1 Like

Hello. Just re-tagging @support to see if there is any advice for my library problem(s) w/ tracks not importing on rescans and playlisted tracks showing as unavailable. Thank you.

Hey @Solomon_Major,

We’re so sorry that you’ve already put in so much effort in importing your Library in Roon, and things still aren’t as they should be. We’d really like to help.

You’ve received really great suggestions from our community (thanks all :pray: ) and thank you for trying them out.

I wonder, would you be able to copy part of your library on a different drive and import from there? This would help us see if there might be anything wrong with the drive you’re currently using.

Also, are all the files a supported file type in Roon?

Hi @support,

Thank you for the response. I have already tried that–copying between a few (external) drives. I am having much the same problem–which is odd, since one of those drives was an old one that had been working fine as a library for several years (my motivation to make the change was simply to use a physically smaller drive and clean up my rack–look at all the problems that that simple idea has caused). Anyway, I cannot get any of the drives to work consistently–as I said (above), wehnI scanned the files, folder-by-folder back into my original USB drive, all was well until I had to restart the machine and a re-scan lost about 90% of the files I’d moved over. I cannot say why this is the case.

To your second question, yes, these are all files supported by Roon. Not only had they been working flawlessly for several years on my old drive, but they are all FLAC (99% 16/44.1, 1% hi-rez; and a literal handful of MP3s). So I don’t believe that this is the problem.

Thank you again. Solomon

Hey @Solomon_Major,

I do appreciate the follow up :pray:

I realize now that this question might not have been asked, and it makes all the difference in the world: when you decided to move your music to a new drive, did you first remove the watched folder in Roon?

If you haven’t, would you please give these steps a try:

1 Like