Library Won't update after 1.5 update

I ripped a cd today onto my mac and Roon will not discover the new album . I tried to force a rescan and the album will still not show up. All albums were updating prior to 1.5 . By the way, the album shows up in Audirvana.

Any suggestions?

Hi @davidh ---- Thank you for sharing this feedback with us. The insight is appreciated!

Just to be clear here. In your report you had mentioned that your library will not update after Roon 1.5 was installed. Besides the album you mentioned in your report has this been the case for everything you have ripped/imported since 1.5 went live? I would like to have a better understand of the scope of the issue.


I’ve have ripped one album since 1.5 and that doesn’t show up . I noticed after about an hour of having Roon opened a couple of Tidal albums I added on my phone showed up .

So I deleted library path , then added path back in and album still didn’t show . Then I deleted that album and ripped it again . Still won’t show . Then weirdly I saw it as a library artist ripped in alac but if I go to the artist page only the tidal version shows but not my rip . The ripped album doesn’t show up in recently added or if I scroll through to artists only the tidal version shows up

I can’t find the ripped album now even though I saw it at one point

Using a Mac , latest version

Ok I found the album under different versions but I have no idea why it didnt show up under recently added. And the album doesnt show up in my albums under that artist.

There is definitely some weird things going on since the update. When I made the ripped cd the primary version over the same title album , my ripped version went into the library under that artist and kicked out the Tidal version. I had to add back that Tidal version and now my ripped album and the Tidal version are in my library for that artist.
Maybe this is a bug,who knows .

I have noticed that if you add a second version of an existing album, it does not appear in the Overview (which is in date added order), but appears with the existing album as a version.

I have added plenty of ripped cd’s where I had the Tidal version in the library and after I finished the rip , it always showed up in recently added .

So i open Roon on my Mac hours later and the ripped version now shows under recently added.

Hmm, buggy.