LibreElec+RoonBridge loses zone after each reboot


I have RoonBridge installed on my RPi 3 + HiFiBerry (and previously on different hardware with the same issue) and have configured RoonBridge to start automatically (Using tips from here: Manual Roon Bridge scripts confused - busybox/bash).

However after each reboot the zone associated with RoonBridge cannot be found by my Roon clients until I disable and then re-enable the ALSA output on that zone via audio settings. Also, that trick only seems to work from the Windows Roon Control Client, and not from my Android app which is still unable to see the ALSA output after disabling/re-enabling it via the app.

Thinking RoonBridge might be trying to access the ALSA outputs too soon before they had fully initialised, I added a delay to the autostart script before RoonBridge but this doesn’t seem to help.

If it was a contention issue between Kodi and RoonBridge for the same output - I would expect the workaround I’m using to fail.

Any ideas?


Just in-case anyone else experiences this issue - I solved it by getting Kodi to use HDMI for it’s audio output leaving the HiFIBerry optical output from RoonBridge’s sole use.

There are a couple of options in Kodi’s audio config that are supposed to help with conflicts sharing the audio output with other applications but modifying these didn’t help in my case.