Linn Akurate DSM streamer not seen by Roon core after the latest update (1.8.987)

Roon Core Machine

QNAP TS-253D NAS
Intel J4125
16gb RAM

Networking Gear & Setup Details

Asus AC86U → English Electric EE8 switch

Connected Audio Devices

Linn Akurate DSM Katalyst

Number of Tracks in Library

46458

Description of Issue

So once again something is broken after an update. Now the core can’t find my streamer after the latest update. This has happened before and it was previously possible to be solved by changing the Linn subnet setting IP address under Setup section but you have removed that setting completely so this is not possible anymore.

See this post and thread for example: Linn DSM disappeared after latest Roon Core Update (1.8, 831) - #14 by patouskii.

The streamer is still visible through Apple Airplay but not as Roon tested device like before. Apple Airplay sound quality is crappy as hell so this is not a workaround.

I tried to reboot the core but it didn’t help.

@support please fix this ASAP.

Thank you for a quick hotfix (988). Now the core sees my Linn streamer again. I can also see the Subnet for Linn streaming -setting again under the setup page.