Linn Akurate / Music stops / Roon Remote not updated

Hi @support

I encountered a problem which I’ve never seen before. I am not sure if it is Linn-related but I never experienced this issue with any of my other network streamers, so I decided to post it here.

I am using a Linn Akurate DS with the latest (non-beta) firmware. Roon core (Debian) and all remotes (mostly Android devices) are updated to the latest version. Both the Roon core and the Linn device are using wired LAN links. The IP address of the Roon core is a fixed IP - the Linn streamer gets a dynamic IP (DHCP pool). In my setup there are various Sonos devices and a Raspberry Pi based device. On those devices I never experienced this kind of behaviour.

The problem:

  • I select an album and press “Play now”
  • The first track is playing but neither the waveform nor the time-information of the track are updated in the Roon Remote app.
  • There is not error message shown in the remote app.
  • If I start another remote on a different device the display situation is identical (no marker in the waveform is moving and the time-information is not changing) (see screenshot below)
  • Everything else in the Roon remote app is working as usual
  • In one case the playback stopped after the first track. Another time the second track of the album started to play (without updating the Roon Remote app) but after track two the playback finally stopped.
  • I was able to start new tracks but the app was never updated and the playback is only working for one song

What I found out so far:

  • After putting the Linn device to sleep and waking it up again the problem remained
  • Stopping/Restarting the Roon remote didn’t change the situation
  • After turning the Linn device off (with the power button) and turning it on the problem was gone and playback worked without any problems for the next few hours.
  • When the problem occured again on the next day I transferred the playback to one of the sonos devices. The app updated and was showing a moving waveform and a counting timer. When I transferred this playback back to the Linn device it still worked. The probelm didn’t come back for the rest of the listening session (a few hours)

I am using the Linn integration since day 1 of its release and never had this issue before.

Any help would be apprechiated.


Thanks for sharing your report with us, @papa.jay!

So we can have a better idea of what you’re experiencing, may I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Just to confirm, playback is not occurring here, correct? Or is it occurring but there’s just no visual indication on the remote?

Are there any patterns to this behavior that you’ve noticed? Does it seem to happen with specific types of content (TIDAL vs local, certain file types, etc.)?

When did you first start noticing this behavior occur? Were there any setup changes around that time, or were any apps that utilize the network (VoIP, AV, etc.) introduced?


hi @dylan,

thanks for the fast reply. I’ll answer those questions first:

Playback is occurring, but there’s no visual indication on the remote. Playback is faultless (no dropouts, no stuttering).

I only use local files, stored on a QNAP NAS. 99% of my collection are FLAC files. The albums which have been played while the problem occured were all FLAC files (16bit/44kHz).

The problem occured last weekend for the first time. I had a listening session on friday. I played two albums in a row. When starting the third album the problem occurred. The second time the problem appeared was one day later. The problem occurred right at the beginning when starting the playback of the first album.

My setup didn’t change around that time. The last software update was the last Roon build (but I had plenty of listening sessions without any problems since then). No recent firmware upgrades on the Linn unit, nor on the NAS or on any of the network equipment.

I’ll send network information later on…

hi @dylan

here is a network diagram which (hopefully) contains all the required information. In case of any questions please get back to me.

Thank you for the details here, @papa.jay!

I think the next step is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thank you!

OK, @dylan… understood. As soon as the problem reappears I’ll let you know…

1 Like

I would like to add that I too have experienced this with my Linn Sneaky, and this has happened since I first enabled Roon with the Linn device. I would suggest it has happened about 80% of the time I have used Roon to stream to the Linn device, and it happens randomly (i.e. sometimes after the 1st song, sometimes after the 2nd song, etc).

hi @dylan,

i started to listen to

Artist: Joe Purday
Album: Who Will Be Next?

on 18:25.

Playback started. In Roon Remote app I can see the album cover but the visual indication (timer, waveform) about the progress of the track is not shown (as reported before). The next song started as well. The situation in Roon remote app remains unchanged. After the second song the playback stopped.

I didn’t touch anything so far. The music is still not playing and Roon remote app is showing the same screen when I started song number 1.

The first logfile entry on Roon core is

08/14 18:25:20 Trace: [raat] RAATServer discovered: RaatServer Papa Jay’s Nexus 10 @

Please let me know in case you need me to do anything else…

Linn firmware is: 4.63.223

@dylan: have you had a chance to look into this issue ? any insights based on my diagnostic logs ?

Hey @papa.jay,

Apologies for the delay here! I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account and gave it some time to try to upload once more. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your Core machine.


hi @dylan,
I am sending you a PM in a second…

@dylan: any news on this ?

I have to say that this problem never occured again since my post 14 days ago. What changed in the meantim: At some point the system updated to build 339 and I had to reboot the Core once because my android app was not connecting to the Core anymore…

Hey @papa.jay,

Thanks for the update here. I checked in with the technical team, and they’re still currently investigating this and trying to reproduce this behavior in-house. It’s good to hear that this behavior has not occurred since your last post! I’ve sent your update along to the team to aid in the investigation and I’ll be sure to update you ASAP when the team provides their feedback.


1 Like

@dylan: i started to listen to music 25 minutes ago and the issue was happening again. I started in my logs at

08/30 10:10:53 Trace: [raat] RAATServer discovered: RaatServer Papa Jay’s Nexus 10 @

The first song was playing and I didn’t specifically look if the visual indication in the Roon Remote app was there or not. The second song was also playing but after song number 2 playback stopped. I looked at the Roon Remote app and saw that the timer besides the waveform was showing 0:00. I was able to start the next song by pressing the play button again but visual indication on the Roon Remote app was not happening. After one song playback stopped again.

I zipped the latest logfiles and put them online again. Link was sent via PM. In case you need anything else please let me know…

hey @dylan

the problem showed up again. Logfile entries of this listening session start at

09/20 18:23:43 Trace: [raat] RAATServer discovered: RaatServer Papa Jay’s Nexus 10 @

First song was playing without visual indication. Second song was play without visual indication. Then the music stopped.

I zipped the latest logfiles and put them online again. Link was sent via PM.

It would be great to get some feedback if you and your colleagues have been able to find the source of this problem.

Hi @dylan

I just wanted to let you know that the problem didn’t reappear since my last post. In the meantime the system was upgraded to the latest Roon build and I got my Akurate DS/1 upgraded to DS/3 (which means, that the mainboard of the unit was replaced by a new one).

Have your colleagues been able to find the source of this problem ?

I’ll report back, in case the problem shows up again.


Hi @papa.jay,

Thanks for the update, we appreciate it! I’ve passed this along to the team. This is still something under investigation, so be sure to let us know if you see the issue return.

Thanks again!

Hi @dylan,

after more than two months the issue reappeared a few minutes ago. The listening session started at “12/28 13:40:47”. I played an album followed by a few tracks from different albums added to the queue.

At “12/28 14:55:25” I started a new song. The song played for 2/3rds. Suddenly the playback stopped. After this event I chose another album for playback. The music started, but there was no visual indication of the playback.

I paused playback. After around 10 minutes I started playback again and visual indication was back to normal. I never experienced this this behaviour before. Up to now I either rebooted the Linn device or the Roon Core but it seeems that a certain amount of time also “fixes” the issue.

I zipped the latest logs and send you the link for download via PM.

In case you need anything let me know.


Hello @papa.jay,

Thanks for posting those timestamps and submitting those logs for analysis. I can confirm that we have received them and I have forwarded them to the QA team who is reviewing your case.

I will be sure to let you know as soon as I hear back with their diagnosis but please be aware that it may take some time due to the holiday season as some staff is out of the office.