Linn Klimax DS not connected after PC wake from sleep

I reported a similar issue about two years ago, now the issue has come back: Roon does not show my Linn DS any more as a zone when the PC wakes from sleep. The Linn still shows up under Airplay devices but the Roon specific Linn connection is gone. Once I quit and restart the Roon server app the Linn shows up again with the queue in the state it was before it disappeared. Unplugging and replugging the Ethernet cable from the Linn or switching the Linn off and then on again does not resolve the issue. Only restarting the Roon server app solves it. I ran some additional checks with other control points (Linn Kazoo, JRiver) on the PC running the core. When I leave either of these control points running when I put the PC to sleep, they remain connected and the Linn shows ready to play immediately on wake of the PC. The same goes for the controllers on my mobile devices.

My core is on a PC running Windows 10 V 1909 build 18363.836. Roon core and remote are V1.7 build 537. The Klimax DS is running software version 4.75.360. Both PC and Linn use static IP addresses. My router is a Unifi USG Pro 4. Both the Linn and the PC running the core are connected to a Unifi Switch 8 via Ethernet. Switch configuration is as recommended in the Roon network best practice. @Support can you please look into this and let me know how to get this back to normal.

P.S.: all my Sonos devices remain connected to the Roon core and work fine immediately after PC wake from sleep.

1 Like

Hello @PSS2P, and thanks for the information. I also took a look at your previous post on this issue so we both have all the data.

First, do you have any Auto Sleep set up on the Linn zone? You can find Auto Sleep (if supported) in the Device Setup tab for the zone (Roon Settings -> Audio -> Cogwheel icon next to zone -> Device Setup).

Secondly, could you please temporarily remove the switch from your network environment and try to reproduce this issue? Thanks!

Hi Nuwriy, thanks for the follow up. Auto sleep was not on. I then turned it on and put the PC to sleep - did not make a difference.

I will dig out my old network gear and replace the managed with an unmanaged switch next weekend. I will report back on what happens after.

Have replaced the Unifi switch with an unmanaged Cisco switch. Did not make any difference, behavior is exactly the same as described in my first post.

Hello @PSS2P, one of the members from the QA team is going to test this out and see if we can reproduce the issue internally. Please stand by and I’ll be in contact with the results.

Hello Technical support. I too have the same problem as PSS2P. My Linn KDSM is never in sleep but when my PC wakes up, it is no longer showing as one of the zones. I have to close Roon down and re-start for it to appear. I have a Sonos on the same network and this always shows. I am currently on a trial and am very impressed with its functionality but I won’t be subscribing if there is no fix for this problem. It’s too much of a drawback. Hope you can help. As an aside, can I migrate the core from my PC to my networked NAS. I’m thinking I’d like Roon access even if my PC is off. Thanks.

Hey @PSS2P,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved. Thanks again for the report!

Thanks for the update and your support. I look forward to a quick resolution of the issue!