Linn player now stops at end of EVERY track

Core Machine (Operating system/System info/Roon build number)
Rock - Roon v 1.7 build 555, RoonOS 1.0 build 186

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Unifi Switch 48 / hardwired Ethernet / all devices on same subnet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Linn DS/Exakt Akubarik

Description Of Issue
A number of us have reported issues over the years with Linn players halting at the end of the track, with Roon thinking the track is continuing to play.

Today one of my Linn players is doing this on EVERY track.

Recently I updated the Linn software to 4.75.360. I do not think we made any other changes. Potentially some change in their software has exacerbated the issue with Roon not playing. I have asked Linn to get me back to a previous version and we will see if this helps

I have tried the same Roon setup with another DS (not Exakt) and it seems to play properly. Tracks also seem to advance properly in Linn’s control point software, Kazoo.

During playing the first track, the pointer showing where the music is within the track is not moving, either on Roon or Kazoo. This is also not something I’ve seen before. Manually moving that point does not position the music – it goes back to where it was (although the pointer stays at the new place). The time numerals are increasing but not to the correct value.

I have reported to Linn but would appreciate some help from Roon also.

Hi - I suffer from this regularly, and as you say the issue has been reported here before - one user resolved it by inserting a switch into the network between his DS and the router. I tried this and it made no difference.
I can sort the problem by power cycling the DS and then it’ll all behave for a few days. The problem usually appears here after the DS hasn’t been played for some hours, and has been left in standby for that time, so the most likely time for it to occur here is in the morning.
I shall watch this thread with interest.


I have 4.75.360 on my Klimax System Hub+Exact 350 integrated speakers. I experienced that problem once a long while ago, but not in the last 6 months that I can recall. Latest Roon version, core on NUC with Ubuntu Server. Everything hardwired with a combination of CAT 5/6, Actiontec MoCA adapters over coax, and Negear switches, with an Ubiquiti EdgeRouter managing DHCP and connection to the outside world. The Linn system wakes up from sleep when I start play, and just does it thing, whether from local files or Qobuz.

Update: I’ve rebooted everything including Rock server; if offered update to 1.7 build 571. Now I seem to be on the second track of an album at last :slight_smile: and I can reposition with the slider.

There is still something quirky here though.

I experience similar problem on and off. The issue seems more prevalent with Roon Radio. After playing the last song it fails to play the prompted song.

Next time it happens (if it does!) just try power cycling your DS and see how it goes.


Yes, I did do that, a couple of times (plus reboots to update the Linn) – to no effect on this occasion.

Ah right, ok. So it’s similar to but not the same as my issue. It seems, when it occurs here, that there’s a lack of communication between the Roon core and the DS, as all of my control points - iPhone, iPad and Windows PC - exhibit the same behaviour regarding the non-moving tracker.


Hi @anonymouse,

Thanks for the report! Can I please ask that you reproduce this issue, note the exact local time + date + track it occurs on and then send us a copy of your Roon logs by using these instructions?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.