Linux: Cannot transition thread 0x7f831c195700 from STATE_BLOCKING with DO_BLOCKING

Hello @support,

Core Machine (Operating system/System info/Roon build number)

[root@grendel ~]# cat /etc/redhat-release
CentOS Linux release 7.7.1908 (Core)
[root@grendel ~]# uname -r
stable[root@grendel RoonServer]# cat /opt/RoonServer/VERSION
1.7 (build 528) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

1GbE Ethernet. Cisco SG300-10 switch. IGMP Snooping off.
No firewalling on CentOS.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon client via Windows Roon Installer 64bit, on Windows 10 Pro 1903.
iFi Micro iDAC 2 via USB on Windows 10 PC.

Description Of Issue

Roon Client can’t connect, because evidently the Roonserver isn’t running properly.

From the CentOS server:

[root@grendel ~]# systemctl -l status roonserver
● roonserver.service - RoonServer
   Loaded: loaded (/etc/systemd/system/roonserver.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2020-03-30 22:55:59 CEST; 34s ago
 Main PID: 20311 (
    Tasks: 46
   CGroup: /system.slice/roonserver.service
           ├─20311 /bin/bash /opt/RoonServer/
           ├─20315 /opt/RoonServer/RoonMono/bin/RoonServer --debug --gc=sgen --server RoonServer.exe
           ├─20878 /pool/opt/RoonServer/RoonMono/bin/RoonAppliance --debug --gc=sgen --server RoonAppliance.exe -watchdogport=44660
           ├─20879 /pool/opt/RoonServer/Server/processreaper 20878
           └─20983 /pool/opt/RoonServer/RoonMono/bin/RAATServer --debug --gc=sgen --server RAATServer.exe

Mar 30 22:56:27 grendel.home[20311]: at Sooloos.SynchronizationContextThread._Dispatch (Sooloos.SynchronizationContextThread/SendOrPostWrapper&) [0x0001e] in <dc03b11aba8c4db1b75c29f20078d986>:0
Mar 30 22:56:27 grendel.home[20311]: at Sooloos.SynchronizationContextThread._Go () [0x00025] in <dc03b11aba8c4db1b75c29f20078d986>:0
Mar 30 22:56:27 grendel.home[20311]: at System.Threading.ThreadHelper.ThreadStart_Context (object) [0x0001f] in <370a0c27f4b74d1a81431037df6d75bf>:0
Mar 30 22:56:27 grendel.home[20311]: Cannot transition thread 0x7f831c195700 from STATE_BLOCKING with DO_BLOCKING
Mar 30 22:56:27 grendel.home[20311]: Error
Mar 30 22:56:29 grendel.home[20311]: Initializing
Mar 30 22:56:29 grendel.home[20311]: Started
Mar 30 22:56:30 grendel.home[20311]: Not responding
Mar 30 22:56:31 grendel.home[20311]: aac_fixed decoder found, checking libavcodec version...
Mar 30 22:56:31 grendel.home[20311]: has mp3float: 1, aac_fixed: 1

Stopping / restarting Roonserver doesn’t help.
I should probably provide you with logs. =)

Sincerely Chris

Hi @CRo,

A few questions:

  1. Can you please upload your full Roon log set to Dropbox / Google Drive / your preferred file sharing service and send me a link?

  2. When did this issue start? Were there any changes to your setup immediately before this behavior started or new media added to the library?

  3. Are you running Plex / Emby on any PC on this network or other apps that use port 1900?

Hi @Noris,

that was the clue - yes, this CentOS server also has an Emby server running on it, which has DLNA enabled (ie. it was using port 1900.)

Stopping Emby (in this case in the form of Jellyfin) and re-starting Roonserver took care of the Roon issue.

I didn’t know Roonserver used DLNA. Is it possible to either disable DLNA in Roon, as I do not want to connect to the music library from any DLNA clients, or if DLNA is required for the Roon client communication to work, can Roon and its remotes / endpoints be told to use a different port? Possibly it’s not specifically DLNA but the SSDP protocol…



Hi @CRo,

Happy to hear my theory panned out and it was port 1900 causing this issue! We use port 1900 for OpenHome which is required for streaming to Linn devices, so disabling this port is not currently possible in Roon.

We have an open ticket with the Devs to see if there can be further improvements in this area since we do realize that other apps (such as Plex/Emby) make use of this port as well.

I can’t specify when exactly this ticket will reach the front of the queue, but glad to hear you have a workaround for the time being.

Hi @noris,

yeah, if one does not have Linn devices, perhaps it’d be nice to have that button somewhere to disable the use of port 1900 .

For example, maybe have it dependant on if you put an IP address into Settings : Setup : Subnet for Linn Streaming (which currently is not non-settable, what if you selected NONE in that pick list?) or whether you simply have a Linn device enabled as an endpoint? If not… turn off 1900. :wink:

Thanks again for your help.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.