Linux sees device, plays fine from Linux, but Roon says "Device Not Found"

HI All,

First, new to Roon but it seems fantastic. Exactly what I have been looking for, for years!

However, I’m having a problem with my USB DAC (headamp pico) on my Linux server. It’s running the roon server/core and works just fine. HDMI output is seen by Rune Core and playback works great.

The problem is the USB DAC. Linux sees it fine, and I can play audio locally.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: DAC [USB Audio DAC], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

However, when I try and enable USB Audio DAC I get the usual “gear icon” and “Device Not Found” next to it. Clicking on the gear icon and the “Retry” option does not help.

Any ideas? This is my last gotcha before I commit to a lifetime licese, it’s a pretty amazing piece of software!

UPDATE: I’m seeing this problem with an USB audio device on this Linux box (running Ubuntu 18.04.02 LTS)

Hi @vijay,

What kind of USB DAC are you using here?

Just to confirm, you’re seeing this DAC in Roon but enabling doesn’t work? Have you tried a different USB cable/USB port?

Hi Dylan,

The DAC is a headamp pico (displays as a Burr Brown DAC in the Roon UI)

yes, I am seeing the DAC in Roon, but enabling it shows “Device Not Found”

And yes, I tried switching ports and cables.

What is interesting is that Linux itself is seeing it just fine and I can select it in the Ubuntu Settings UI and play audio through it via VLC etc just fine. In other words, there is nothing that doesn’t work on the Linux side of things, it’s only the Roon Remote Client (well, I suppose technically it’s the Roon Server, but I’m seeing the error message on the client, of course) that says “Device Not Found”



Hi @vijay,

Moving forward I’d like to enable diagnostics on your account so the team can take a closer look at what you’re experiencing.

First, please reproduce this behavior (click Enable so it shows Device Not Found) and make a note of the time you do so. Respond here with that time and your timezone and I’ll enable diagnostics.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.