Linux x64: Roon server crashing after adding one specific album

Core Machine (Operating system/System info/Roon build number)

Readynas 6.10.1 (Debian 8)
Roon: Linux 4.4.178.x68_64, Version 1.6 (build 416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connected SoTm SmS-200Ultra, Router Netgear NightHawk, Managed Switch Zyxel GS1920.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sotm SMS-200Ultra + Chord Dave

Description Of Issue

Hello Roon support,

After adding one specific album from Tidal, the roon server app starts to take all CPU and never stops. It’s no longer accessible and just cycles between ‘Initializing’, ‘Ready’ and ‘Failed to connect’ states in the clients. Clients are able to connect for about 3 seconds, then again are all disconnected.
Tried to delete the full install, and reinstall from scratch with a restore.
This worked ok until I tried to add this specific album again.

Album added:
Leonard Cohen
You Want It Darker

Please let me know how I can reslove this.


Hi @StefanK,

I just tried adding this particular TIDAL album on my end and have not experienced any issues, so I think there is a little more going on here than just this album being added. If you were to try adding this album with a fresh database, before doing the restore, do you see the same behavior occur?

Hi @dylan,

Just did a test and you are right. On blank library I have no issue adding this album.
So it must be something with my existing library and this album.
Let me know how would you like to proceed to find the root cause of this issue.


Thanks for giving that a go, @StefanK!

Moving forward, I’d like to enable some diagnostics on your account so we can take a closer look. First I was hoping you could reproduce this issue and make a note of the time you experience the crash. Respond here with that timestamp and we enable diagnostics and take a closer look.

Hi @dylan,

Just did a new test adding the album with my full library loaded.
Time was 19:37 CEST 10/06.
Right after the album wa added, playback has stopped and the clients are no longer able to connect. To be precise they connect, but get disconnected after like 2-3 seconds. This is then repeating all the time. Server app is running at 100%cpu all the time.

Plese let me know when I can kill it, I would like to avoid some damage to my NAS.


FYI, had to kill the Roon Server process, it was really messing up my NAS. Let me know if I should re-start it for some time again. For the moment it’s down so I can actually use my NAS.

Hi @StefanK,

Apologies for the delay here — Diagnostics have been enabled and the next time you start up RoonServer on this machine the diagnostics will be uploaded to our servers. When you’re able to, can you start things up and let it run for a ~15 minutes so the diagnostics report can come through?


Hi @dylan,

I ran the server from 14:37 to 15:00 CEST. Hope you got the diagnostics. I’m killing it now.

Thanks, @StefanK. The diagnostics report was received and the team is currently analyzing the report. I’ll be sure to update you ASAP when I’ve received their feedback on this.

Hi @dylan,

Is there any word yet from the technical team? I’ve now tried to add the same album via Qobuz, but the result is the same.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.