Live Radio - anyone else seeing this weirdness

This isn’t a support request because it’s not bothersome enough to try to troubleshoot. But just in case others are seeing this, you’re not crazy:

—Go to Live Radio.

—Click a Radio Station.

—Click Play.

—Roon says “station does not exist” (paraphrase, I don’t recall exactly) and doesn’t play

—Hit “back”

—Click on same Radio Station again

—Click “Play”

—It Plays. Sometimes it requires one or two more backs and forwards to play.

Roon just seems to lack confidence sometimes?

Similarly, I’d like to see Roon keep trying a radio station once play has been clicked rather than to stop the stream and just sit there whenever the stream is momentarily interrupted. Live Radio just seems to die sometimes and need play to be reclicked for no good reason.


Yea, that’s exactly what happens for me on multiple stations right now.

Yes on all points. I go to another saved station, start it up successfully then go to desired station (or just stay where I am, and enjoy😊).

Yes, for the past 4-5 days

I too confitm this behaviour for, im case belgian radio stations.
And indeed, although it happened sporadically before, it is unfortunately consistent for the last week or do

+1 from Germany, no matter the radio’s origin country, more frequent since build 710 but not every time.

Same here. This happens for me between both FLAC streams of Radio Paradise.

Yes, I have seen this more often recently.

Each morning I check on the thirty odd flac streams that are out there. (I don’t use Roon for this, instead I have a Linux script.) It is quite normal for one or two of those, no more, to fail to connect in the first 4 seconds (my default) first-time. They generally do on a retry.

FWIW, I have noticed no change in the last week. As I said, Roon not involved.

Well, Roon is involved in the message it pops. What if, every time you called someone that didn’t answer, instead of voicemail you got a “called person does not exist” message from your phone?

Roon could simply say “waiting for stream…keep waiting?” [Yes][No]

Roon’s error messaging is often pretty misleading…not helpful for troubleshooting. This is a great example.

Sorry, I should have been clearer.
What I meant was that Roon is not involved in my tests. As I’m not seeing the issues there, the conclusion is that the issues must have something to do with Roon.

Ah, got it. Yes, I seem to reach that conclusion a lot.

Personally, I believe there is a serious resource leak issue of some sort where Roon slows itself to non-functionality over the course of hours/days and has to be restarted. Given how long it takes to start up again, the restart requirement is too frequent.

Same here - I can no longer play any of my radio stations (for 3 - 4 days now)

The stations have not changed names, adresses or configurations, and are definitely up and running.

Roon seems to be the problem.

Hello @Alexander_Holy, would you mind letting me know a couple of the stations you are having problems with? I’ll see if I can reproduce.

This problem has improved for me over the past day or so.

Edit: Nevermind, it just occurred again with Radio Paradise - Mellow Mix. It really doesn’t seem to matter the station. It’s as if the db that is the list of radio stations is having trouble responding quickly.

1 Like

WBUR (Boston public radio) seems to regularly have the issue. As in I feel like every time I try to start it, I get that sequence of issues followed by success.strong text

Same here as well, looking at the logs it looks like Roon cloud is saying the stream doesn’t exist a few times i.e until you click out and back into the stream and then it finally comes back with a 200 OK.

In some cases it has taken 5000 mS to come back with a 304 which is “address hasn’t changed, use your cached one” quickly followed by a 404.

Think Roon need to up the AWS computing.

I reproduced this this morning with WBUR. I had previously connected via a direct linux connection (interestingly, it took two goes).
Repeated connections were then OK. So, station stream active. As far as I can see, there is no redirection or relay.

Next I tried Roon, and got the error. Tried a different station, then returned, and all OK.

Rebooted my server, and everything still OK. Certainly seems a backend Roon problem.

@dylan, anything changed at the servers? I have logs if you wish.

1 Like

Much appreciation @BrianW for knowing your way around the logs!

Stations involved were Stations in Austria:
“ORF: Radio FM4”
“ORF: Österreich 1”

The Error was/is intermittent “Station no longer exists”