Loading new Tidal or Qobuz album can take 3-4 tries before displaying

Core Machine (Operating system/System info/Roon build number)

NUC8i7 , Rock, build 505

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Velop Mesh Router, DataLink switch, Rock on wired ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Various Ropieee

Description Of Issue

Tidal and Qobuz has become very slow and erratic. When loading the Tidal or Qobuz tab or loading a new album within either it can take 3 or more loads before the page is complete or the album displays.

I have tried all the usual fixes - delete cache, change DNS to, log out and in. This is the same whether I am using my iPhone as controller or my Macbook Pro as a controller or my iPad as a controller. This has become a problem since upgrading to 1.7.

I have experienced occasional similar issues in my system since the upgrade to 1.7 (NUC8i5, Rock, build 505 and Linn Klimax DS/1 or sonore microRendu/Mytek Brooklyn+; front end control app primarily on Windows 10 Pro).

I also invariably get a message “error loading page” when I enter ‘Tidal’ from my Roon menu. This is despite the fact that the page does appear to have fully loaded correctly. Choosing to ‘reload’ the page gets rid of the message.

1 Like

Hi @Progisus,

I would like to try to narrow down this issue further, can you please create a Backup of your Roon Database and then temporarily use the Macbook Pro as a Roon Core and verify if the same behavior occurs there?

As my music is on an ssd in the Nuc I assume I would do a restore to the MBP and just test with Tidal and Qobuz? Would the MBP need to be connected to the same switch and port or just somewhere on the network?

Hello @Progisus,

Yes, that is correct.

Yes, connecting to the same port/switch would ensure we change as few variables as possible.

OK, I’ll look into that tomorrow.

1 Like

So… using the MBP as the core connected to same ethernet cable and switch port worked perfectly and instantly. I have left it connected for now. It must be something to do with the NUC. Suggestions?

I also tried updating bios. Still no joy. I also tried different cable and port, no luck. I also tried reinstalling the operating system through the web page. Any ideas?

I once again moved core to MBP. I noticed Fail to load appeared on the MBP as well. That meant it was not NUC. I changed the router dns to my providers dns, powered down the modem, removed coax feed and waited couple minutes. Powered up modem and returned core to Nuc. Success!!! Back to the music. Thanks.

1 Like

HI @Progisus,

Glad to hear you were able to narrow down the issue to the DNS servers, hope you have a continued enjoyable Roon experience!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.