Loading ROCK to NUC10i3

Roon Core Machine


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Unable to get NUC to Boot - have tried all the BIOS settings suggested in community including NUC10i7 settings posted by Steve. Still no luck

Welcome to the Roon community, @Richard_Treasure.

It’d be really helpful if you described the problems you have experienced with each step taken.

Please use the following help guide.

Hi Martin, Thanks for getting back to me.
I am pleased that you support the NUC10i3. Mine is the NUCi3FNK.
I have followed all the steps recommended in the link you sent to a tee. As noted elsewhere in several threads, this guide is out of date for the latest iterations of the NUC, I think since version 8. As I discovered today in trying to set up my NUC10 device, I just cant get the bias settings right, I have tried the process in the link you sent, where I get a screen with extremely small text in the top right corner asking if I wanted a new installation (press 1 or 2); I press 1 then enter and then just the dark screen and nothing, I have gone through and checked my bias settings a few times. I am puzzled as in a NUC10i7 guide posted on the site by Stephen, several of his settings are different to what has been previously recommended - those settings at least get me to a screen where the text is normal size and fills the screen, i am asked to choose a boot device, I choose boot from USB but I am getting a " Reboot and Select proper Device" error.

Hi Martin, If I may add …
In the BIAS setup when I go to
The Boot option priorities I am getting 3 options
UEFI: PXE IPv4 Intel(R) Ethernet
UEFI: PXE IPv6 Intel(R) Ethernet
UEFI: USBDisk RunDisk 1.00, Par

No option for SSD

Then running the setup after pressing F10…
I get options and choose the USB option
It then shows in microtext in the top right corner of the screen
Welcome to the Roon Optimised Core Kit setup
Would you like to:

  1. Install ROCK on this device?
  2. Recover a previous install of ROCK on this device?

Please type a number 1 or 2

The screen goes blank, nothing for several minutes

Kindly note that I am a community member, and not a Roon employee. The BIOS settings are described in a linked article, and this is up-to-date since UEFI boot is enable, and this is a recent addition to ROCK.

Incidently, who is Stephen? Please point us to the guide you are following. Thanks.

Hi Martin, Thanks for your contact I very much appreciate it.

The link to Stephen’s thread. The one thing his settings help with is that I am now seeing the
Samsung SSD as part of the boot options. i dont get that with the official roon guide - but unfortunately with Stephen’s guide i am getting the “Reboot and Select proper Device” error.

I am fairly sure that I am just 1 or 2 settings away from success.

Stephen’s thread is from 2020, and ROCK received a major update recently to support UEFI boot, so that guide is not up-to-date.

Please use the ROCK: Configuring BIOS On Your NUC posted earlier, and take a screenshot of any option you’re unclear about.

You’re booting to the Rock installer if you see the menu.

I presume you press 1! It’s possible your tv/monitor is not switching resolutions, but the install is working. Try forcing the display to re-adjust to the video signal.

Thanks for help guys, it installed - It as set to settings as advised by Martin, seemingly no luck, I was looking again at the BIOS settings, turned it on with F2 pressed, and it just started installing, screen resolution correct - everything. WoAHAR! Now cant figure out how to see the Data folder = it just says type \ROCK\ in windows explorer - anyway will put more time into it this afternoon. Getting closer to finding out what Roon is like!

Now have SMB working and can see the Data Folder thanks to these instructions

I apologize for not being present or much help. I haven’t touched my NUC since the original setup because I’ve never had an issue with it. I use an external portable hard drive connected to it for my small library–I use Qobuz exclusively through Roon. I suppose I could upgrade the firmware, but there is no need since it’s working perfectly. I used Tidal a while ago but decided to use only one service.

Good luck!

Hi Steve
Thanks for checking in.
I am all set now. My setup will be similar to yours.
In my case Tidal with Roon and will build a small library at some point.
I have had to do a reset more than once due to the
system stalling but other than that very happy with it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.