Logged in to Tidal, search ok but cannot play any Tidal songs

I have the same problem since last update. I am logged in in Tidal, i can search etc but cannot play any songs from tidal. Library songs do play fine, radio plays fine, only Tidal not.
“This track is not currently available from Tidal”
“Too many failures Stopping playback”
Please help!!

1 Like

Hi @M_v.d_Vathorst,

So Roon’s @support team can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hi @M_v.d_Vathorst,

Please do provide the setup info when possible. One other troubleshooting step I would try here is to log out of TIDAL and back in via the Roon Settings -> Services tab.

4 posts were merged into an existing topic: Trouble logging in to TIDAL - with new method


The problem started after the last update a few days ago. Before that all worked fine. I did not change anything in my hardware setup.
I already logged out/in several times in Tidal. I also restarted my NUC twice after the update but that does also not help. As I said, Tidal looks like it is working, i can find songs and select them but cannot play any Tidal song.

NUC core i7 with Roon on SSD and music library on external Synology via ethernet.
Lumin U1 connected with ethernet to internal network and USB connected to Kii Three speakers.
MacBook Pro, iPad Air and iPhone 11 as remotes, all do not play Tidal songs.
I haven no library issues, and radio works fine so the network is ok, The Tidal app on OSX and iOS also works fine, only in Roon not anymore.

It was my mistake, sorry. Somehow I have multiple Tidal accounts where I can log in, but only one of them has the correct subscription. It went wrong after I had to log in again after the update. The new Tidal log-in does not work very good yet. After logging in it took several log-out log-ins before Roon started to see my account. But finally it works now!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.