Logitech Transporter and Roon won't connect

I’m having a strange issue. This week I changed my network router. I had been using a Linksys router with four Velop mesh wifi units around the apartment and switched to an Asus Zen wifi setup.

My Logitech Transporter had been working just fine in my kitchen connected by wifi to the Roon core running on an SonicTransport i9 in another room. The Sonic Transport i9 is connected by optical ethernet to my network which is fairly extensive encompassing my entertainment system in the living room and the computers in my Computer room.

Wifi covers both my apartment and the apartment next door so there are quite a few devices on it including televisions, laptops, tablets, and phones. Everything is working just fine except this one issue.

As you can see from the enclosed images the Transporter can see the server but the server won’t connect to the transporter. Can anyone explain why the two are disconnecting? At this point I have power cycled both several times. Made sure I am using the latest software, checked all of the IP addresses (which the new Asus units did change of course) and am at a loss to understand what is happening.

Looking at the Roon logs I found the following lines repeated a couple of time …

08/26 14:15:01 Info: [squeezebox/client] [] connected
08/26 14:15:01 Trace: [squeezebox/client] [] GOT HELO device_id=5 revision=87 mac=00:04:20:10:1b:83 uuid=00000000-0000-0000-0000-000000000000 wlan_channel_list=32768 bytes_received=0 language=EN capabilities=
08/26 14:15:01 Info: [squeezebox/client] [] Device Data: modelkey=transporter model=Squeezebox Transporter uuid=00000000-0000-0000-0000-000000000000 name= mac=00:04:20:10:1b:83 ipendpoint=
08/26 14:15:07 Trace: [squeezebox/client] [] Didn't get HELO within 5s. Closing client connection
08/26 14:15:07 Trace: [squeezebox/client] [] State Change Initializing => Disconnected

Even if just as a test, can you connect the Transporter to the network using Ethernet? Any improvement? Based on the logs you shared it looks like the Core is losing the transporter and so Ethernet might add some stability to allow the connection to stay.

I guess I could try that. I would need to move it to another location while attempting it. However I might add that the Transporter reports it has a 100% wifi connection so that really shouldn’t cause a delay and the wifi is now much stronger and faster than before as I also had my ISP upgrade my internet to 1 gig this week. Thanks very much for the suggestion.

OK, so I connected the Transporter via ethernet and it connected immediately. Unfortunately, I can’t really run a cable to it’s location in my kitchen. Once back in it’s home position it went right back to refusing to connect. So it’s definitely a wifi problem but I have no idea what. I tried turning off the firewall on the Asus wifi but that didn’t help.

The logitech transporter wifi only supports up to 802.11g, maybe your wifi is on network ac or ax?

I thought for a moment ah, maybe that’s it BUT it has connected to the wifi just fine and reports 99 - 100 % signal. It just won’t connect to the ROON server.

It is indeed an AX system but…

Is WiFi 6 ax backwards compatible?

WiFi 6(802.11ax) is definitely backwards compatible with WiFi 5(802.1ac). If you turn on WiFi 6 mode, the ASUS AX Router will communicate with other legacy devices.

I would set up a different, separate wifi network for g, having both the Roon Core and the logitech transporter on the same wifi network g. My Google mesh wifi allows 2 separate wifi networks, and I guess your new router would do the same.

Btw, I have the original Logiech Transporter and have no issue, whether it is on wifi or on wired network.

Never mind, I see your Roon Core is on a wired ethernet network.
But I think it does not do any harm to create a second wifi network for 802.11g, maybe it works?

1 Like

Well, that is an interesting thought and I would imagine not too hard to implement. I will look into it. Thanks for the suggestion.

Well, eventually this was solved. I don’t think that the Asus units were putting out a very good signal and added a very expensive Asus gaming router and put the other units in MESH mode with it. Since then the problem has gone away.