Lone missing CD

Roon Core Machine

Roon Server, MacOS Monterrey, Mac mini M1

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

15,000 tracks

Description of Issue

Guys, I tried to avoid posting here but I’m stumped. I have a single CD that I have ripped that simply will not show up in Roon. Every other CD in the folder does. It’s a simple 16 bit 44.1 CD. I’ve restarted the core. I’m baffled. Any ideas?

I’ve also tried forcing a rescan of the directory to no avail. I’m hoping this is the only CD that is missing

I don’t think I’ve ever really encountered this problem before.

Are there any special characters or unusual number of characters in the file name of the album or any of it’s tracks?

No. I’ll double check but pretty sure, no. Thanks.

And just like that… The CD has appeared. I had a Qobuz copy in the library and once I deleted that I was able to access the CD I ripped. Normally you can see both. Very weird. Anyway solution found.

Try clicking on “Show hidden tracks and albums.” Maybe that will help.


When you had the Qobuz copy in your library, did you see a “Versions” tab when viewing the album?

Yeah, normally that’s how it works although in this case, no. Searching for the CD title in Roon, restricted to local files only, yielded zero results, and those always show up in search.

Strange indeed. :thinking:

Yeah I’m at a loss. The Qobuz version is a higher sample rate, but I hesitate to re-add. Never ran into this before. Perhaps I was doing something wrong, but I don’t think so. Thanks.

1 Like

Hi @Doug_Hannah ,

If you try to re-add the CD, are you able to reproduce the issue?

Not that but when I tried adding another CD later the same thing happened. It turns out the common denominator was that I already had some version of the same album in my library from Qobuz.

As you know normally when there’s multiple versions you see those versions, and can find them in search, but in these particular cases is the only version I could see was the Qobuz version. Removing the Qobuz version allowed me to find the versions I had ripped.

It’s almost like the software was automatically hiding the local copy, which I know is not how it’s designed

I don’t ever remember this happening before.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.